Lag using huion tablet


i just got a new huion 680s tablet and its experiencing a lot of lag when i use the brush tool. it also will draw lines where i dont want them in between the strokes i make. its pretty unusable! drawing with my mouse works fine, as well as drawing with the tablet in photoshop or other programs. i have pencil Version: 0.6.0, running on mac el capitan. any help would be much appreciated!

@luke Hi, In the past other users have mentioned similar issues, but after they updated to their latest hardware drivers their issues went away. However I believe that was for Windows OS, and I don’t know if there’s a fix for MAC or Linux systems.

For now I’m afraid we can’t provide you with a definitive solution until this issues has been investigated. If you’d like to help us out, while also ensuring that you can work on your own projects, please try out the free software Krita ( If you don’t have issues with that program in the same manner that you do with Pencil2D, we might be able to cut down the time it takes to realize a proper fix while we review how they might have solved the same issue.

I’ll tag developer @CandyFace hoping that he can help us unravel the mystery of the HUION tablets on MAC.

— Note for developers —

Aside from user testing here’s a site that has a collection of drivers for different tablet brands aimed for linux distros, could this help to widen our support for these other brands that are getting into the market not only for Linux but for MAC OS?

There’s one for the HUION H690, I wonder it that one would help?

Hey thanks! I tried Krita. It’s better, but after a bit of drawing it develops a lag, but only in “letting go” of a click. For instance, I will draw something, but when i lift my pen it will continue drawing for a second or two

Hmm if it occurs in Krita too then it could be a qt problem, hard to say really… I don’t have my Huion tablet currently so I can’t test it again… I did test the stable release with my tablet some time ago and didn’t have any issues on my macbook with sierra.

@luke have you tried uninstalling the huion driver and reinstalling it? also did you install the driver from cd or the latest from their website?

i havent tried that, ill give it a shot. and i donwloaded it from online, their latest one