[Investigate] Problem report while using the bucket tool.

lesliekunz said: "Hey there! I’m new to Pencil and this Forum. Thank you for this community, it’s pretty awesome.

When I try to fill with the bucket in vector layers it’s only filling red, but not in the bitmap. Anyone come across that and knows how to fix it?


obiwan362 said: I’m having the exact same problem. I’m selecting a color from the palette on the right, but it still fills everything in with red.

@lesliekunz @obiwan362

Since both of you have similar issues I’ll create a new thread for your problem so you can find it quickly. Please answer as a comment here what I’m going to ask next:

First of all let us know which version of pencil you are using.

You can know which Pencil2D version you have by going to Help > About

If you can, please take some screenshots and embed them into the post. You can upload them into imgur.com and just paste the image link on the forum post. Or even better record a video to show your problem if you have some time.

If you can’t do this then at least try to post a step by step procedure to point out how the problem occurs every time, so the developers can investigate what is the problem.

I hope this isn’t too much to ask, but if we don’t learn more about the problem and how it happens we won’t be able to fix it. Thank you for your understanding, we’ll be pending on your response.

Thank you so much. So the version I’m using is 0.5.4 (26 July 2013). Is there a newer one? Also I uploaded 2 screenshots of the problem to imgur, but I don’t really know what to do after. Can you find it or do I need to tag it or upload it here in this forum? I called it Pencil: all the colors (purple) fill red.


@lesliekunz Yes we have some newer development versions, they are a bit more unstable but they fix several other problems that have been reported in the past. You can download them here:

You don’t have to “install” them just click for the appropriate link for your OS, and download the one with the newer date. Then extract the contents of the zip file inside a folder and open the executable file like you would normally.

Regarding the imgur thing, it’s actually pretty easy, you can right click each image and you’ll get a popup on your browser (usually) press the “copy link address” option and paste it on the posts and they will become embedded.

Since you pasted the imgur album link for now i’ll do it for you so other devs can see it, no worries :slight_smile:

Since you have a MAC, it seems to me that indeed the latest version will fix this problem, but please try those versions out and let us know if it fixes the issue for the time being.

If you have any other issues that have not been reported here, please let us know:

I’m also using v. 0.5.4 (23 July 2013). I’m on Windows though and having the same issue.

In messing with things, I realized that I could change the fill color, but to do so, I needed to select the paint brush tool, select a new color, then select the fill bucket. That would let me fill with a color other than red.

@obiwan362 That is actually super weird because I have Windows 7, I’m testing it right now on the 0.5.4b version (the one for download in this website) and on any bitmap or vector layer, I can change the color of the buckettool using the color wheel or the palette, while i have that tool selected. Hmm.

Do you have Windows 7, 8 or 10?

Can you try out the nightly builds to see if if works better for you?


If it’s needed I can make a quick video to show what I’m doing exactly, maybe to spark any ideas on what might be happening to you.

I also am using Windows 7, SP1. However, I’m realizing that you mentioned a color wheel, and I only have the palette and the sliders for color selection.

Is there a specific nightly build that would be better to use than the others, or should I just try the most recent?

@obiwan362 Here is a graphical explanation of how to access the Colour Box / gradient slider and how to work with it.

Okay, I know how to do that. Sorry, I thought you were referring to an actual wheel. :stuck_out_tongue:

@obiwan362 Sorry I was not clear. The latest development versions have a color wheel + sliders for ease of use, the color box still exists but since it was so “hidden” another dev thought it was a great add to have that wheel.

Download the most recent nightly build from 2016 by visiting the other thread I linked in a previous comment if you’d like to see what has been changed so far and what remains the same. Have fun :slight_smile:

hi there :wink: i have the exact same issue on windows 10 pencil v 0.5.4 from july 2013, although v 0.4.4 is working fine for me . the issue only occurs on vetor layers

@doryfor Have you tried using the Nightly builds to see if this problem persists? The other users never got back to me to answer if the development version was free of this bug.

Why test with the Nightly build? because it’s the closest snapshot to the next stable release. So if you try it out and you find this bug is still there, I’d like to ask you to document it in detail so we can report it over the github, which holds our bucket list for bugs to-be-fixed. Thanks :slight_smile:

ok, so i downloaded the latest nightly buil (from th 8th march, right?)
theire are some cool features, which i really like but the bucket tool works bizarrely, sometimes it fills the shape sometimes not (on vector layers). i have windows 10 here is some footage for you:

as you can see, it takes several random trials to fill in a shape. also, they do not always fill correctly.
i also noticed a random german word when renaming a bitmap/vector layer, it says abbrechen instead of cancel.
lastly, has the view path key changed? it used to be fn+F1 on my pc, which doesn’t seem to work for me anymore
thank you for your time and good luck continuing developing pencil!

@doryfor Well I just wanted to know if the red color issue was gone with the newer version, if it did I’m glad, that means one less bug.

However the Bucket Fill is wonky because the developer who was working on it hasn’t fixed the remainder of the tool, fortunately we already know about this so I’m hoping whenever we get an actual new version this will be fixed properly.

Also the problems you mention are indeed weird, the translation shouldn’t be working yet. Also the F1 toggle was disabled but the function still exist, it is the “Show Outlines Only” button found in the display Panel.

For now I can only think of linking you the only decent version I have of Pencil 0.5.4b which actually has a color wheel and probably has the red fill bug fixed (since I’ve never experienced it first hand).


ok thanks for the info :slight_smile: in the mean time i’ll keep using v 0.4.4b

Hi, thanks so much for this updated version (the on with the colourwheel). I too have had this problem with the bucket fill in vector, but in bitmap it fills the wrong layer! This new version is fantastic! I love pencil - such a powerful product =)

Just registered and will certainly donate time - I’ll look deeper into what skills (?) I can offer. Thank you, and thanks for the forum

@siobhanhallen the vector fill issue was indeed fixed, however the way the bucket fill works is just “different” for animation sake. The idea I get the original developer was trying to convey was to separate the lineart from the color work (fill), since in animation we have different graphic treatments for a single drawing and usually inside a studio these are worked by different departments.

I made a video earlier about Pencil2D’s coloring methods for both bitmap and vector layers. The fill tool behaves differently with both layer types so I hope you find it useful since it explains why the color sort of Bleeds to the layer below when using a bitmap layer.

Around the 15:00 minute mark I speak about this in detail, the first half is all about vector stuff. Hope this helps :slight_smile: