[Investigate] Pencil2D crashes after duplicating frame

shadofx said:

Reproducible Error: Unhandled exception at 0x0031803F in Pencil.exe: 0xC0000005: Access violation reading location 0x00000008.
— Open Pencil.exe
— Create a new frame at 5
— Delete the frame created by default at 1
— Press duplicate
— Program crashes


@shadofx I’ve tried this but mine doesn’t crash.
  1. What version are you using?

  2. Which operative system are you using?

Initially you’re not supposed to delete the keyframe at frame 1 it creates problems afterwards.

Our developers are already aware of this problem and are looking for ways to allow to properly delete the first frame. Thank you for your report, but in the future please create reports by creating threads like this one inside the Bugs Report forum, not on your profile update :slight_smile:

I literally cant delete the first frame. I guess it was fixed in the Jan 14th nightly build.

@sumit_makwana The only way to delete the “first” frame is to create a new frame. Basically it is because you always need to have an active frame on your timeline. It’s like always having a “piece of paper” in your stack. No paper = no drawing, so to speak :slight_smile:

But I think this is getting investigated by feeef so hopefully peoplw won’t worry much about that.

@morr actually I already tried with add another frame in the same layer, and it still wudnt delete the 1st frame. Is it like bound to a particular layer type?(vector/bitmap/camera) Because I tried to recreate the situation in each layer and it still wudnt delete the first frame.

The only notable change is that if I draw something on the first frame, and delete the keyframe. The drawing is erased but the frame still remains. Adding another keyframe brings the same result.

@sumit_makwana I was assuming the original poster had the download page version (0.5.4b) where you can delete the first frame only by creating a new frame.

But if you’re talking about the latest Nightly Build, yes, you can’t delete the first frame or it will crash, but don’t worry this is an already known bug.