Imported images show up at different resolution

See title: I’ve set my canvas to be 960x720 rez, and drew a 1920x720 background for it (it needs to pan across). Here’s the issue: when imported, the image is smaller than the canvas size and needs to be resized to fit correctly, making it blurry. Very frustrating, and I don’t know if it’s my fault or the software’s. Any advice?

This is how it looks: inexplicable white bands at the top and bottom, even when I have the camera layer selected.

1 Like

@bluef00t Hi, as usual. which version of Pencil2D are you using (please state the date of the download file that comes on the zip file name)

Let’s try the following:

  1. Please select the camera layer and press CTRL +H This will reset the camera position, and will help us to notice if your camera has been moved previously even if unintentionally.

After trying this:

  1. Please try to import your background again with File > import. If this doesn’t work
  2. Please try to copy & paste it from what ever program you’re using to create it, you can quickly copy and paste between programs.

If that still doesn’t work, please save the file with a different name and upload it to dropbox, or google drive so developers can take a look to see if there’s a problem with the particular version you are using.

@JoseMoreno @bluef00t

Out of curiosity and because I’ll be doing something similar to this soon I tried to replicate this with version 0.6.0 and it works fine. At one point I thought something fishy was going on but it was just that I needed to press CTRL + H to reset the camera zoom/position.

Ack, first post, forgot to check out the date. I’ve got the December 1 2017 version I think. CTRL+H DID solve my problem! I’ve been doing my best to avoid using the camera function, as I’m still not very good with it, but it seems I managed to mess it up anyhow.
Thank you for the advice!

Ah, new issue. The rest of my animation is now no longer at the correct size against the background… is there a way to resize them all at once? I might attempt to export them as an image sequence at the right (smaller) size, then just import them back after I’ve corrected the zoom.

@bluef00t If you pressed CTRL+H to reset the camera and it worked, then it’s easy. What is happening is that when you select the camera layer and reset it’s position, it will go back to it’s original location (when you create a new file), so it is framing the relative resolution of 960x720 at 100% zoom.
When you’re zooming in or out, think of it as if the camera was actually moving forwards or backwards, so the canvas size becomes smaller or large, but the resolution (the frame) stays the same. That’s why is might not be matching.

Since I only see one keyframe on your timeline, it’s because that one camera keyframe is controlling the distance of the camera to the canvas for the whole timeline. Now, remember that you can keyframe these motions.

So you can to duplicate the original camera layer keyframe (use the duplicate button to copy the current camera position) move it so it won’t damage the rest of the animation, and then reset the other camera key(s) where you see fit.

Normally I see two ways to do the pans in Pencil2D:

  1. Leave the background in place, use a bitmap layer to indicate the layout for the camera displacement, then keyframe the camera layer to the guides, animate the characters doing their thing and finally animate the pan as a last step to track the characters.

  2. If it’s a really long walk cycle Leave the character in place, leave the camera in place, and move the background.

If you still can’t seem to fix it, and if you want, send me the file and i’ll check it out to see what’s happening to help device a workaround.

On a different note

We recommend that you download a more recent nightly Build if you find you’re having troubles with either the sound, or the export.

And please try to save copies of your file in case something goes wrong and the file won’t open, that way you can fall back to your previously saved backup copy.

Select the camera layer and then press ctrl and scroll with your mouse to fix the resolution, I don’t know how to fix the snapping perimeter detection tho :(

@Elecy_Griphen This thread is over 4 years old, and @JoseMoreno has already provided quite a comprehensive answer after which the original poster did not have any further questions. Please refrain from reviving old threads like this without a good reason.