Import image sequence

I’m trying to import an image sequence in my timeline, but I always get one blank frame in between 2 images (i.e., if I import a sequence of 10 images, I get 20 frames). Why is that? I’ve tried to change the fps rate in my timeline, but I always get a double number of frames imported.

@intefrodrigo Hi. Please download the newest version. Do not use version 0.5.4.

Once you try again to import still images or image sequences, if it continues to fail, let us know.

Latest version for windows is
Latest version for MAC is

On the other hand this is indeed a behaviour that has not been fixed nor determined. Since this software was originally thought for traditional animators it imports img sequences in two’s, however often times with digital works this is not the case.

Hopefully this can be implemented soon, but for now you’ll have to move each keyframe manually.

I’ll make sure to report this so it’s not forgotten and I’ll link to this thread so the lead developer know that there is demand for it.

As a cheap trick to import the frames sequentially you can make a gif with your files and then import the gif into Pencil using the File > Import > Image command.

In that case it will import every single frame next to each other. This is not the best way but it works for now while the issue is solved.

Gracias! I’m working with a pencil 2d nightly build in arch Linux.