Images (JPGs, TIFFs, GIFs) not loading (but PNGs do) -- bug?

I am new to Pencil2D. It seems like the perfect animation software I need for the simple stuff I need to do … But for the life of me, I can’t even load a simple image … I have tried .JPG, .TIF, and .GIF (both lowercase and uppercase). However, .PNG work well.

I installed Pencil2D on Windows10 and Windows7, with the same result.

Anyone with the same problem?

Thanks in advance!


@albert_folch Hi Albert, I assume you are using the 0.5.4b version that it’s available for download in the website right?

Because what you describe appears to be a bug that was reported 3 years ago in a previous version (the lowercase vs upper case problem is particular to that) which is not available for download.

If you don’t have this version please visit our download page:

Anyway I’ve just tried to import images with that same version 0.5.4b out of the box and these file formats work:

jpeg, jpg, bmp, tif (with a single F), .gif (if you import animated gifs, it will import the first frame only).

Here are the steps I take to do this.

  1. Open Pencil2D.exe
  2. Either create a new Bitmap Layer OR Select a Bitmap Layer on the timeline

Note: It’s very important to select the Bitmap layer, if any other layer type is selected, nothing will import properly.

  1. Go to File > Import > Image…
  2. The Folder Explorer Window will appear. On the bottom right hand side, select the filetype you want to import (PNG, JPG, etc)

  1. Files from the selected filetype ONLY will appear in your Folder Explorer Window
  2. Select the file you want and press Open

If after following these steps you still can’t open other filetype besides PNG, please try to download some of our newest -but experimental- downloads which are pretty much working with fixed stuff, although are still prone to crash, but devs are working hard on stabilizing the software.

Hope this helps, but please let us know if it does.

Hi there,

My problem is that I want to export as .png so I can put it on top of life action on iMovies, but when I export it as .png it hasn’t a transparent background to put on top of other picture or video.

I have that same version.

Would you know how to fix it? I just want it to have a transparent background.


Thank you so much.

@lesliekunz Heya Leslie, I see, If I understand correctly your PNG’s don’t have a transparent background. Take note that when you export a single image (like in my previous post) it’s a bit different than when you export an image sequence.

It seems that Exporting a single image by using the File > Export > Image option does not enable transparency, however if you export an individual image, using the “image sequence” option you’ll be able to get transparency for PNG images. So please try out to export your transparent images going through the following steps:

  1. Select your Camera Layer. This is important or your image will not be displayed correctly!
  2. Go to File > Export > Image Sequence
  3. A “Folder Browser Window” will appear as usual. Input your image name, select PNG from the filetype dropdown list and Press OK / Accept.
  4. A new smaller window that says “Options” will appear: Leave the resolution values alone (since they are set to your Camera Layer viewer), and make sure the “Format” entry says “PNG” then press OK.

If you have a few frames drawn, each one will be exported with transparency and with a number next to the name you wrote.

If you only have one drawing, it will only export that drawing with transparency.

Let me know if this worked out for you, or if you need visual assistance, so maybe I can make a gif or something. :slight_smile:

Hi Jose,

Thank you very much! I do have version 05.4.b (I’m a new user). The first instructions didn’t work, but the most recent nightly build was able to load a JPEG.

BTW, I don’t know if it’s related to this or not, but the previous version gives the following warning on a black screen on my Win10 system:

Initialize win32: <nothing, for now>

WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded




Tool Option Widget connect to Editor


Thanks again!


@albert_foch I’m glad the newer versions helped you out, hopefully we will have a more stable version coming through 2016.

Regarding the error message that appears in that black window it is related to some missing files that enable Pencil2D to read audio, and everyone suffers from it. However that is a larger problem that is being solved right now, so don’t worry about it it does not affect other capabilities.

My take on this is that since version 0.5.4b was made to work with older versions of the coding framework we use, hence only older versions of Windows and Mac OSX will allow it. So newer operative systems will have a problem by initializing every aspect of the program that runs “under the hood”. We’ve had other reports of issues with Windows 10, although they are different everytime. That is just my point of view but I might be mistaken.

Anyway, if you need more assistance let us know. Cheers.