image importing help?

I am fairly new to the Pencil2d community, and have played around with the different features it offers before running into this issue. I am unable now to import any image on any layer, whether the form is .jpg or .png. Whenever I try to import an image, an error comes up saying “unable to load bitmap image. tip: use bitmap layer to import bitmap images.” I had successfully imported an image before and only recently have run into this problem, any suggestions on how to solve this?

Good evening Megan, I’m going to ask you if you’re using Pencil’s current “stable” version 0.54 beta found in the downloads section

If you have this version then, the error hints to the possibility that you are not importing the image directly towards a bitmap layer.

So please select your bitmap layer, then select any keyframe by clicking over it (the pink square must turn dark grey when selected) then immediately go to File>Import > Image … > PNG

Anything but PNG Images wont work both for import or export with this version.

If you can’t import certain PNG files, double check they are actual png files, sometimes people rename JPG to PNG and leave it like that so when you download them you can’t tell the difference…but truth is you’re geting a JPEG compression algorithm with the PNG filetype in name only.

Hope this helps, if it doesn’t let us know what version you do have currently by going to the menu Help > About > and you’ll see your current version in the following format: Version: 0.#.# (xx month xx)

Hi Jose, you solved my problem! Thank you so much for your help!

My Question = Will there Ever be a stable Pencil version?
After all these years every effort to use Pencil ends with a MEGA Crash!

It’s so Frustrating!

(Sorry, but it happens for the 1000 time before I wrote this!)

Love the tool, but I see no improvement!

The basic problems are after all these years still there!

Waiting still on Pencil 0.5.5.

@megannilsson You’re welcome Megan, glad to help :slight_smile:

@aardman246: I’m sorry to hear you’ve been experiencing such difficulties.

Truth is, after the french devs dropped the project and Matt Chang rescued it from certain death, right now this is pretty much a one man show. He’s doing it for free, and he dissapears from the public from time to time (though he stills merges code in the github page) since I bet he needs to work and eat.

I completely know how you feel aardman246, because pencil is the only software of it’s kind in the open source world right now, and it could be damn good.

Not Synfig, Tupi, or even the newly added 2D Capability in Blender would rival this software if it was fully functional. But that is not the case right now. Matt has been doing what he can to migrate the code to newer (easier) platforms so others can pickup where it’s been left. But even for such a “simple” app, it’s a lot of work. Right now though, unless Qt C++ devs get interested in this project, nothing will change as fast as the users want.

I even downloaded the project and tried to take a look at the code. I got lost, I’ve coded in Python, and learned “some” C++ in the past, but I have no idea how to develop functional software, without a software blueprint. Sadly I’m an artist not a programmer.

So my only way to contribute to this is to make stuff in pencil and show it to the world. But to be absolutely honest, I’m in awe how someone can even make stuff with it in the first place. It’s already difficult to do classical animation as it is, but if one can’t draw in a decent manner it’s all over and I have heck of a hard time drawing in pencil. On the other hand I don’t want to end up doing motion graphics.

Again, I understand where you stand, but a one man rodeo can’t pull this off so easily I’m afraid, even with the recent rise in people contributing to the code, those who want to help need directives, a roadplan so to speak, which I don’t know where to look or how to create given the opportunity.

For now I can only reccommend to use the version that is on the download page, and save often. If anything, ask any programmer friend of yours to take a look at the project. That would be a huge help if he or she gets hooked.

On the bright side you could wait for the Krita animation plugin if you want a taste of open source 2d animation capability with a minimum of stability for you as a user, but that will also take some time.

This said, I’ve been increasingly interested in making tutorials on how to actually use pencil to animate without dying (avoiding “app crash” pitfalls, if it’s even possible), but right now I’m too busy, so for the moment it’s just wishful thinking / planning on my behalf.


Jose, thank you for your wide answer.

It’s very clear now what the problem is.

And Matt Chang thank you for all the time and hard work you put into Pencil!

I myself haven’t any knowledge of programming so there’s nothing I can do.

But my love for Pencil wil be forever;0

ican’t get my png picture show up its just plank screen its takes the comands but i cant see my picture

@esa-petteri_holkko Hi would you mind letting me know the following information?

  1. Which version of Pencil you are using. To find out go to Help > About
  2. Which Operative System you are using. i.e Windows 7, MAC OSx “El Capitan”, Linux Mint 17, etc
  3. If it’s not a private picture, would you mind sharing the picture “file” by uploading it to and posting a link to that file so we can test it out?

I’ll also ask you to double-check if you are selecting the correct layer during the import.

If you are importing a PNG, JPG, GIF, or TIF you MUST select the bitmap layer first, then go to File > Import > Image otherwise it will not import, no matter what you do.

Also, check that the layer you are importing has it’s visibility enabled. Every layer has a little circle to the left of it’s name. You just have to see if it is filled grey or black (turned ON) or if it’s empty (Turned OFF)

For now I’ll be pending your response to continue with the troubleshooting :slight_smile: