I tried to draw with the pencil tool and it wouldn't work


#1

I was working on my animation, and then I tried to draw using the pencil tool, and it didn’t work!


(Jose Moreno) #2

@Sparkle Hi, if you were using the vector layer, the tools have different functionality and the Pencil tool is meant for invisible lines to color shadows. To see invisible lines you have to enable the appropriate button on the “display” panel. Right now the vector layer is being repaired so please don’t use it.

If you were using a Bitmap layer, please make sure you are using the latest version which you can download here http://pencil2d.org/download

If you’re using the latest version please send us a screenshot (or better yet a GIF) and let us know know which operating system you are using.

To record GIF’s easily and without issue you can dowload a free tool called LICEcap https://www.cockos.com/licecap/


(kaiko) #3

It happened to me more than once, but I wasn’t able to have it working, or at least to follow some steps to figure it out.
The pencil tool refused to draw, and meanwhile all remaining tools and panels where not reacting to the pen action, but the tool cursor was moving OK

Win 8.1 x 64bits
Nightly build 05/10/2018


(kaiko) #4

When the camera layer is accidentally clicked it may bring this situation and all drawing tools will not work (meaning they will not be able to draw on the “canvas”)
But as mentioned before, this was not my case, since panels and controls were unresponsive to the pen as well


(Jose Moreno) #5

@kaiko I’m honestly testing really hard to block the pencil or pen tool but it keeps working for me. It’s possible that you or the OP pressed ALT by mistake, this brings the eye dropper tool and I noticed that If you press it quickly it locks the tools really bad (which wasn’t happening)

The other possibility is your graphcis tablet. If both of you have HUION then it might be related to those drivers. (I only mention it because I know you have HUION)

For now I don’t really know what else might be causing trouble.


(kaiko) #6

It happened just a few times so far, but it stopped doing so lately


(scribblemaniac) #7

Sounds similar to this issue. Has it happened to you in v0.6.2 or a later version?


(kaiko) #8

As I am no longer able to simulate the issue again (it is working just fine now), I am not sure what triggered that situation.
It happened with the nightly build from 05/10/2018

Thanks