I can't open the animation file


#1

Hello i’m having a problem with opening one of my animation on Pencil2D…
I’ve been working on it for a couple of days but suddenly today Pencil says that it can’t open that kind of file and I think it’s mistaking the animation for an image.
I didn’t change the extention, i tried to restart the pc but it didn’t work… What do i do?


(Jose Moreno) #2

@Eunice Hi, first allow me to ask a few questions that I’d like you to respond with on your next comment:

  1. What is your current Operating System (e.g. Windows 10, MAC OS 10.11, Ubuntu Linux 13.10, etc)
  2. What is your current version of Pencil2D. To learn about this go to the HELP menu > ABOUT option and use the “copy to clipboard” button if there is one. If not there should be a date and a version number.
  3. Has Pencil2D crashed when you’ve tried to save your file?

Alright now for a possible solution, please do the following:

  1. Duplicate the PCLX project file to have a backup.
  2. Take the new duplicate and rename the file extension to .ZIP

If you can’t see the file extensions then depending on your operating system you might be able to visualize them:

Windows: http://www.thewindowsclub.com/show-file-extensions-in-windows
MAC OSX: http://www.idownloadblog.com/2014/10/29/how-to-show-or-hide-filename-extensions-in-os-x-yosemite/

  1. Once you’ve change the filetype extension, open the file with a ZIP File Manager like Winzip (windows), 7-zip (cross-platform) or Pea-zip (MAC)

  2. Extract the contents of the file on your hard drive, and you’ll get a folder and hopefully a main.xml file

  3. If the main.xml is lost, you only get the folder and it will come with all the “raw” images but without the position information on the canvas, so you’ll have to re-organize them on your timeline again.

To understand the order of those images, their names should be in the format 00X.000X, (e.g 003.0012) which means the drawing was on the third layer and the 12th frame on the timeline.

If you tried this and you couldn’t handle it, please upload your project file on a cloud storage service you trust and paste a link here.

If your Pencil2D version is older than version 0.6, I’m afraid it’s possible that your work is lost. If you used a newer version then you’ll be able to recover the folder with the images.

This has been happening less and less, but it still does to a few people, however there have been improvements done along the way to counter it in the latest development versions which we hope to ship soon, but I urge you to ALWAYS have a backup file to avoid this kind of issues meanwhile the program becomes more stable.

Please let us know how it goes.


#3

Hi, i have Windows, i downloaded my version of Pencil2D yesterday but I erased it after the bug and I downloaded it again today thinking it would read the animation file so i think the version i had yesterday, that i used to create the animation, is probably the same as the one i got today (version 0.6 or the latest i think). When I last saved the animation it didn’t crash or anything like that in fact i thought everything was fine but then when I tried to open it, it couldn’t read it…
I tried what you said to do but 7zip gives me an error, it says that it can’t be extracted and if I change the extention it says that it’s not possible to open it, while all the other animations can be opened and extracted, that one in particular doesn’t work anymore.


(Jose Moreno) #4

@Eunice Please upload the PCLX file in a cloud storage service like google drive, dropbox, mega.nz or any other that you are comfortable using and paste the link here so we can take a look. Just a small disclaimer, it is possible even after that we won’t be able to recover anything, because if the files were wiped clean nothing can be done. This usually happened with older version of Pencil2D (which is why I asked about the version)

For now let’s hope we can at least help you and try to get the drawings so your work is not completely wasted, but from here on I do recommend having multiple backup copies to avoid having to do this as we’ve honestly had no luck finding what causes this issue and it’s been investigated a lot. We’ll continue to look further to avoid these issues but nothing beats having at least a backup copy handy.

I’ll wait for the link to the file in order to help you futher.