hHowTO get rid of the 'P2D text credit' when exporting a movie

I’m ‘ALL-IN’ for giving credit where credit is due. However with all due respect to the creators of P2D, how do we get rid of/turn-off the ‘P2D - name of movie’ at the bottom of our movies??

(Welcome to the forums!)

Is this kind of thing occurring?!

Could you send a screenshot? This doesn’t happen to me…

Also, what version do you use?


1 Like

Thx for your reply…

Thanks for the reply. I’m using - P2D VERSION 0-6-6

I’m using Mac OS Ventura 13.2.1

Thanks for providing the additional information. That text definitely wasn’t added by Pencil2D, however. Most likely, it is an informational overlay added by your video player to show which file is being played (i.e. the text is not actually part of the exported video but is added by your video player during playback). If the text bothers you, you could try looking for an option to turn it off in the preferences of your video player. If the video player you’re using happens to be VLC, try right-clicking on the video and selecting the menu entry Tools → Preferences. Then go to the “Subtitles / OSD” section and uncheck the “show media title on video start” option. If you’re using another video player, you might be able to find an option like that elsewhere.

1 Like

Thanks Jakob for your reply.

Yes I’am using VLC and will try your suggestion ASAP!

@mikeyatesusa Hi, welcome to the forum. To my knowledge and practice with the Pencil2D software, the app does not have any kind of watermark at export.

From your latest screenshot it seems that the name of the movie file is being displayed by the video player, but that’s a configuration on the video Player, it’s not something Pencil2D has control over.

This kind of situation, where certain video players show the name of the file during playback is common and can be configured in their respective application settings. It’s not a Pencil2D domain, but a domain of the player app

If you were to upload the video to youtube or similar platforms you would not see any kind of watermark aside from whatever you have added to it inside the animation software or via a video editing app.

Edit: It seems I was a bit late with my Reply. Jakob’s reply is more useful considering he already provided a solution to the specific video player you are using. Either way, we hope you can solve your issue soon :slight_smile:

1 Like

Thanks for the info…very informative…

FYI - ‘Quicktime Player’ can not play or recognize .avi or .mov from P2D.


Quicktime player is made specifically to play MOV files and other files related to the Apple ecosystem, since it is a video player developed by apple.

It should show MP4 files as long as they have H264 encoding, which is what Pencil2D exports by default

However Pencil2D does not export MOV files currently.

1 Like

Thanks JoseMoreno for your input as well!

Alright everyone thanks for your time…Case closed and will move on…


Thanks Jakob for your suggestion concerning the VLC text at the bottom of screen. Your suggestion of disabling/unchecking the box for OSD worked in VLC.

Good job!

1 Like

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.