Help with pencil??

I have Pencil V0.5 beta, and everything is working fine
But when i put the audio in pencil it comes out silent when i push play.

I i am unable to download the other pencil version for mac because they don’t work for my mac and only the beta works.
So my question is:
Is there a way to fix this?

I already downloaded a windows version with my mac using wine and the audio feature worked.
Im confused can someone shed some light on my question.

My god how did it do this XD

How can i delete this question.

Hey Montserrat, you can edit your posts and even your forum threads here :).

There is an edit button on the top-right side of any post next to the ID number for that post (e.g #1608).

Regarding your question, yes, the audio has not been working on some builds, even in the old 0.5 beta, i have tested the audio feature in the most recent build for our pencil2D here for windows and it doesn’t work either.

I think the phonon.dll library (which is the one that pencil looks to run the audio process) is still not linked in the code as of now (that means the code is not looking for the library properly), although the .dll comes bundled with pencil.

If you need assistance with anything else regarding the software let us know :slight_smile:

I’ll take advantage of your post too and report that such audio feature is broken so the following stuff is for the Devs.

I get the following code in the separate debug window when i initialize pencil:

WARNING: Bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded.

Then when i go and import an mp3 sound into a new sound layer it gives the same error as before and then it goes goes like this:

WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon:: AudioOutput ( no objectName)

Any attempt to play through the timeline will just tell me the phonon plug-in can’t be loaded

For the moment we will have to wait for @Matt so he can answer us, hope that answered your queries as well @Montserrat