Frames lag behind sound :(

I have a section where the camera layer moves, and when that happens the frames lag behind the sound and it gets at least 10 seconds behind the sound, and it never catches up and stays out of sync the rest of the time :(( how do i fix this?

i got rid of the camera movement, but the frames still lag significantly when it hits that point- ive tried reloading it and it still slows right there.

@terminallyTestified Hi. The development team is aware of the synchronization issues with sound. I’m afraid this varies from computer to computer as some people report from 1 to 3 fps delay while others report as you 10 up to 20 fps.

We’ve found that using MP3 files causes issues with playback sync (like when you start to play from a different place on the timeline) so we’re advising to use WAV files instead. You can convert MP3 to WAV by using the free audio editor Audacity (http://audacityteam.org)

This will probably not reduce the lag by a big amount but it should help the playback to be a bit more “faithful”.

That said, if you want to add sound to your final animation, we suggest you only use sound in Pencil2D for rough timing purposes until this is fixed (ETA Pending), and use a video editor to finalize the sound tracks for your animation.

There are various free video editors we know of, so here’s a list:

Free / Open-Source Video Editors

Open-Source

Free

thank you!! but i dont think its a problem with the audio? its that the fps slows. its not the audio lagging, and it does this even when i start from the beginning, or whatever location i start from its always just the one spot that gets it messed up D:

@terminallyTestified Hmm. To be honest there’s little I can do to check for more issues through the forum. If you’re able please send us a link to your file where the problem can be experienced.

You can use wetransfer.com and follow this guide to use their anonymous link option (will delete itself in 1 week) https://wetransfer.zendesk.com/hc/en-us/articles/115004254743-How-do-I-send-a-link-transfer-

I also forgot to ask, does this happen when you export the movie as well? or only during the editor playback?

If it happens only during the editor playback, it could be due to how Pencil2D stores frames on the computer memory.

There’s a limit to how many frames can be stored at any given time, and once the playback goes past the default number it slows down a bit. After a few plays it should work fine again though.

Just in case please try going to Edit > Preferences > General Tab > Advanced Section > Cached Frame Number and try to put a bigger number like 512 (default is 200)

Note that this will require to to have at least 4 gygabytes of RAM, as Pencil2D will try to hold more frames in memory so the playback is smoother. If this improves the playback “lag” in that part you mention. Let us know. If not, please default the number to 200 and let us know as well.

1 Like

i hadnt exported it yet to see but i did and it did go at the normal speed!! uhh i changed the cached frame number to be higher and that didnt seem to help so i changed it back to 200. thank you for your help! :]

What is the fps of your project? How many layers do you have? A higher fps or more layers will make it harder for your preview to keep up.

12 fps and i have 5 total layers so yeah haha i see why it would do that- although i had an earlier animation w the same and no problem, idk tho this one is wayyy more complex- and i actually am using the camera this time lol. im not finished but it worked when i exported it soooo ill just leave it until im done!

@terminallyTestified Ah alright, Thanks for trying out those troubleshooting tips. If it’s working during export but not on the editor something else could be causing the problem.

With that said we’d be very interested in the possibility of having your file shared for a tech review. Other than that, if you have any other issue let us know.

p.s. Make sure to save extra copies of your animation file to prevent file corruption if your animation becomes too long and a fortuitous accident occurs (i.e blackout while saving on a single file) . Good luck!:slight_smile:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint