Frames erased but not gone (Mac)

Just for clarity, I’m running OSX Al Capitan 10.11.3

So, I saved my project and closed out of, and then went through the pcl.data folder and clicked on the .vec file. When the file opened, it showed the frames in the timeline, but appears as if there the drawings have been erased. Does this have something to do with the vector layer?

 

I’d also like to point out that while all of the .pngs were all saved in the pcl.data folder, they were saved improperly, I guess, because their dimensions have been switched around a ton. Random amounts of space have been added to the sides of each .png, so now when I go to put them back in the project, I would have to line up every frame.

 

PLEASE, PLEASE HELP ME.

@jacob_swanson We had an entry on our FAQ called “Understanding Pencil2D Save Files” here:

http://www.pencil2d.org/faq/

However I’ll explain it a bit more in depth in here so please read carefully.

First let me state that I don’t think your file has been damaged, unless you saved over what you already did.

Basically what happens is that the PNG files that are stored in the folder are NOT the final frames as you see them in Pencil2D, they are just literally the strokes that you drew on a particular layer auto-saved with transparency.

Pencil2D “white background” is just a visual mockup, everything you export as a final image with a PNG format (which supports transparency) will only show the strokes unless you explicitly paint /import a background.

The images inside the folder that appear in the picture are named like “001.002.png” which means that such particular image was drawn on the second frame of the first layer that was created since the beginning of the file, which is not necessarily the actual “first” layer, as you could have deleted other layers previously, but pencil2D has an absolute index for it’s layers i.e you create 5 layers but delete the first three, your layers will be numbered as 004 and 005 although they are now the first and second active / visible layers.

The .VEC file is a special file that tells pencil what happens with the vector layers. Since vector lines are mathematically created the vector lines are written here as programming code.

You are not to open the .VEC file and unless you know what you’re doing, the pcl.data folder is NOT to be tinkered with. You just really have to open the .PCL or .PCLX file with pencil2D, which is outside the “pcl.data” folder.

However if you want to understand how these files work, you can open them with a text editor, then you’ll realize that is only an XML file, which is basically a fancy address book that points out to the Pencil2D app where and how is supposed to display the stuff you draw.

So in essence what the pencil2D .PCL file does with this information is to “remember” where those strokes are placed on the canvas- invidualized as separate .PNG’s - while referencing a cartesian coordinate system (0,0 is the center of the canvas)

IF after reading this and opening your .PCL file with pencil2D is not helping at all with your problem, please use PeaZip for MAC and compress a ZIP file that contains:

  1. .PCL file

  2. pcl.data folder

Upload it on mega.nz or dropbox or whichever service you deem fit, so our devs can take a look at it. However I’m 99% positive that the problem lies in the way that you’re trying to open the original file through the folder and not with the pencil file itself.

I’ll be pending your response, so let us know what happens to see if we can continue to provide you with proper support!

Thanks, friend!

I think it had to do with the way I had opened up the file… unfortunately I’m not sure quite how to get the strokes back. It’s like they’ve disappeared. So what I think you’re saying is that I should not touch the pcl.data in any case? To just open the file through the app itself?

@jacob_swanson Exactly, just open the pencil file through the app :slight_smile:

Also since you’re using “El Capitan” OSX the old version of pencil2D (0.5.4b) might give you some additional problems. If you experience any odd behaviour try using the latest development build for MAC OSX that was released on January 14th 2016. The filename is Pencil2D-mac-20160114.zip which you can download here:

https://drive.google.com/folderview?id=0BxdcdOiOmg-CcWhLazdKR1oydHM&usp=sharing#list

And any time these “builds” are updated you can check it out in this thread:

http://www.pencil2d.org/forums/topic/pencil2d-nightly-builds-2015/

I did had this exact thing, but it bitmap. this is for school, youre talking to a very angry 7th grader, and i NEED to get this file back!!! could you please walk me through how to do it?

@BrooklynTheGreat Sorry to hear you’ve had a similar issue.

If you were using a newer version of Pencil2D there might be hope. I don’t have a MAC so I’ll try my best to put the proper steps.

  1. Make a copy of the .PCLX file.

  2. Rename the file format to ZIP

  3. Use a ZIP file Manager to open the file. If you don’t have one, for mac there’s a free program called “pea-zip” http://www.peazip.org/

  4. Inside the PCLX file you’ll find a folder. Extract the folder

  5. Inside that folder you should be able to find the “RAW” bitmap drawings which are not “properly” positioned, but you can re import them and move them again to try to get your animation workign again.

However If you see files but they are blank, I’m afraid there’s nothing we can do as this was a problem caused by older versions of the software which is why newer versions were made and we tried to let everyone know they shouldn’t use the older version due to the possibility of these kind of things happening.

I also can try looking at your file to see if something else can be done. So if you want upload the project file (the one with PCLX extension next to the name) to any service like google drive, dropbox, mega.nz, etc and leave a link as a response.

Edit: One last thing. While we review the file you upload, please start working on your animation again just in case so you can turn in your work in time. File recovery has a low chance of success so don’t count on this as your last resort. :slightly_frowning_face:

If you want use another software just to be safe. Here’s a list with other possible software. You could even try commercial software on trial just to finish your work.
http://pencil2d-software.tumblr.com/post/145767476221/when-youve-worked-all-day-on-your-animation

@CandyFace Sorry to bother you, do you know how to access the “temp” files in MAC to check for previously opened Pencil2D files? I only know how to do that in windows. Maybe that way there’s a good chance to recover these files for the latest person who replied on this thread.

@JoseMoreno sorry for the late reply.
The temp folder is MUCH more hidden on mac os… or at least the default location Qt uses… so an example of how the location could look like: “/var/folders/bh/zv8zgx7j6zjgbjtjnrsfq5g80000gn/T/Pencil2D/Default.Y2xD/”

this part “/bh/zv8zgx7j6zjgbjtjnrsfq5g80000gn/” however is generated and thus could be anything.

To locate this location without having debugger available is not easy, although you can also just go to /var/folders/ then search for pencil2D

thank you for your help, but it didnt work. but i think it had to do with the autosave. it seems like everytime it auto saved, it would erase a frame. i turned auto save off, and now my animation is fine. do you know why that is?

umm how did you do that? i mean i turned off auto save too but now what? what did you do to recover your animation? :c

i didnt recover it. the ffirst part of my animation is gone. about 130 frames

oh, i see… :l that must suck
well, thx for answering me anyways n.n/

no problem. and yeah, it does suck. but if it ever happens to you, just dont lose your cool.

but question:how do i do a voiceover??

@BrooklynTheGreat @blehbleh :frowning: Sorry to hear nothing worked, we’re seriously doing our best to find a way so this things won’t happen anymore but it’s not small feat. Sigh.

My only advice for now is to save several copies of your project during the time you work on it, so you can fall back if these things happen again, and instead of losing 130 frames, maybe 4 or 5. We talk about that kind of habit building in our FAQ here: https://www.pencil2d.org/doc/faq.html#pencil-crashed-and-my-files-are-unusable--corrupted

But more importantly, please don’t feel compelled to use Pencil2D, hopefully if you find a software that is better suited for your workflow please use that. We hope to continue improving the software but I ain’t gonna lie to you, it will take time and since we’re not a company or anything, just volunteers it will be harder than it sounds.

i understand. but how do you do a voiceover??

@BrooklynTheGreat If you want to do a voice over you need a recording software. You could use audacity (http://audacityteam.org) to record your voice while playing back the video and then use the voice recording and the video with a video editor (https://kdenlive.org/en/ Kdenlive is also free and it’s professional software) so you can edit the voice along the video for web.

is the video editing software a zip file, too?

i got it open. how do import or uploead or whatever my animation to it?

@BrooklynTheGreat Not necessarily. You could use a installer.

If you’re talking about Kdenlive, I suggest you watch the tutorials on their site: https://userbase.kde.org/Kdenlive/Manual/Tutorials