Frames are missing?!


(Leonie) #1

Hey, I made an animation and saved it, but when I opened it up later some of the frames were missing! Well, the layer still had the frames registered, but they were now blank, and I KNOW they were there before I saved and closed the application. I don’t know why this has happened :frowning: it’s only a 9 framed animation, but 3 of the frames are now blank, seemingly random ones too.
I tried recovering them by turning to file to a ZIP and viewing the frames, but they weren’t there either.

As for the version, I’m not sure. But, it’s new enough to have the new icons. I think it was a nightly version?

Why does this happen, and are the missing frames retrievable?
Thanks.


(Jose Moreno) #2

@Prismaticette Hi. Sorry to hear you’re having difficulties. I’m afraid that if the drawings weren’t inside the PCLX turned ZIP file they might be lost.

If you’re positive that you were using a nightly build this might confirm someone else’s report that there’s a chance you end up losing random drawings while working, however it’s very difficult to pinpoint the cause right now so If I may ask the following:

  1. Please make sure you’re working with a nightly build (2018), if you’re working with anything older than version 0.6.1, the older bugs would be causing those issues.
  2. Did you notice the frames were missing before, during or after saving?
  3. Were the files missing after reloading the file?
  4. Has this happened before? If so when and how?
  5. Sometimes it happens that when you load a file using the “open recent” command it laods the file but the drawings aren’t there. So you have to load the files using the “open” command. Q: Did you use the open recent command by any chance?
  6. What OS and what version are you using? (Is it MAC OSX? Windows? etc)

(Jose Moreno) #3

@CandyFace Hey man sorry to bother you, It seems that people have been losing frames at random in the nightlies for some time now.

There’s another written report on the discord channel (in #bug-discussion, use the search bar and enter this phrase: “I mean the frames were there but just blank”) but the other one said frames were lost after having a lot of drawings (over 1000), and this one has fewer drawings (less than 50). Could either be related to the issue you were fixing before? The one where you would save and the drawings scrambled and got messed up? Or could it be something else? What do you think?


(Oliver) #4

@JoseMoreno

A few things has been done in the “recent” nightlies that could be causing problems here… one thing addresses the scrambling issue, the other thing which @chchwy applied makes sure that only content which is used is being zipped.

If the problem is related to the first case, then you would be able to see it as soon as a save action has been executed.

For the second case, you’ll first notice problems when opening the project again from .pclx because it selectively looks at what files are being used and zips those.

We’ll need to know when any of these problems occur so we can debug the situation accordingly.


(Leonie) #5

Thanks for the reply and help. To answer questions about the issue:

  1. yep, I believe it’s the most up to date version.
  2. I can’t confirm, but I’m pretty sure they were there before closing. It’s only when I reopened it they were missing.
  3. Yes they were still missing, same ones.
  4. Well, I worked again on the animation recently redrew the frames and all. Saved, reopened it and now half of those frames are missing…
  5. I probably used the open recently… I’ll try to avoid doing that and see if it works.
  6. Windows 10

(Jose Moreno) #6

@Prismaticette There was a problem where having your save operation interrupted will result in the structure file to become corrupted. It will be fixed for the upcoming release 0.6.2.

We also have been dealing with another case as of yesterday, very similar to yours where some frames were lost, which has to do with how the files are being opened by the program. The devs are looking into it as we speak actually and I believe they pushed a fix to test if it solves the problem in the long run.

For now please don’t try to open the same file, or any file, in rapid succession (that is, pressing open recent or open, loading a file, and if its blank, then try to load it again) as the issue appears to be related to the loading of the file too.

The workaround Instead for loading a file is: IF you just started out the program, you can open the first file if your work session normally, but if you were working on another file, press “File > New File” first and then use the loading commands to bring your file.

What is happening is that if you load the files quickly the temporary files will not be created in the temp folder of your OS, so the file that you load appears blank while in reality it is not, it’s just that it can’t read anything because nothing was extracted from the PCLX / ZIP file.

Sadly if the frames are not saved inside the project file there’s little hope to recover them but as a last resort you can try out this guide I made on the following comment: