Fixing the Vector engine

I have been working on Pencil last night. I fixed some issues with the colour wheel that was incompatible with the colour palette.

In the way the code is done right now, one has to use the colour palette when drawing on a Vector layer. Each vector stroke is linked to a colour in the colour palette so when changing the colour in the colour wheel updates the current selected colour in the colour palette and all the vector strokes that have been made with this palette colour.

Changing this behaviour at this point requires a lot of refactoring so I left it like that as it is usable. It can be even quite useful if we want to ajust colours in one go in the entire project. We just need to show users how it works.

Bitmap drawings are not concerned by this as each stroke are independant.

You can have a look at the latest updates on my branch

I don’t have access to a Windows PC right now so I am not able to build a binary. I am only using Linux. The best thing you could do is install QTCreator on your PC and build the app from there. You need to download the source of the project, open the pencil.pro file with QTCreator, validate the default configuration and click the run button.Opefully, there will be no error and you will see the Pencil window opening.

I will do a pull request to the main branch.

PS : I have also fixed the behaviour of the onion skin.

i can share my 64bit build from your branch, but as i wrote (provably in the wrong forum) i can’t build 32bit versions for some reason, i have 32 bit versions of MSVC 2013 from another project i built and MinGW too but i can’t seem to use either of them as kits/compilers, not in their 32 bit variation just 64

-> http://www.mediafire.com/download/ecur4oc19kjhhq1/Pencil2D_feeef_64bit.zip

i’d gladly help you with windows packages but i just need to know how to do the 32 bit ones

 

 

 

Hi feeef, super that you gave us an update so quickly. Thank you very much !!!

I just happened to stumble upon an important thing regarding Pencil2D, I guess this has been brought up before and who knows maybe I’m doing something wrong but I just thought I would ask here about this behaviour.

When colouring images the result I get is not the desired result.Take a look at this sample image. Nr.1 is colored in Pencil (Don’t mind the difference in colors) and Nr.2 is colored in Paint.Net.

The question is is there a way to fix this way Pencil2D colors images, it’s a huge show stopper for me I just realized when I’m getting more serious about doing a project in Pencil2D. I had added a Vector layer beneath my line drawing as I think I read about that here somewhere, but ouch ! what a ugly result nr.1 gives me compared to what Paint.Net does.

Can this be easily fixed, hope so :slight_smile: Not that I’m demanding anything I just thought it’s interesting and should be fixed if isn’t just me. :slight_smile:

http://imgur.com/7GjO8bB

I think I somewhat managed to build a 32-bit version. There are issues though and I don’t know if they are present in the 64 bit version Mr.Studio provides.

  1. Export movie doesn’t work, no requester whatsoever.

  2. Step to next frame doesn’t happen at all if you try to use shortcut keys (at least customized ones that i use)

  3. If you zoom via shortcut keys I have to klick key (zoom+) and press pen on to drawing area (like a click) to make zoom happen. Behaves the same zooming out.

8 Nov 2015, 32-bit version here:

 

Thank you guys for your comments and your support! Thank you for building a Windows version!

@manu, are you commenting about ugly lines after colouring? Or is it about the colour not being respected?

There was a problem with the onion skin system changing colours on the current frame. After making a stroke, it was changing it to dark blue. I had fixed that on the version on my branch.

Maybe you are refering to something else if you are using the version from my branch?

I have still not fixed anything about the bucket tool. It will be the next step. After that we should have an almost stable bitmap and vector engine.

The ability of combining bitmap and vector makes this software so cool!

I investigated the issue I had with coloring, it’s not anything wrong with Pencil I think. The bucket tool works well now when I know how to use it. I’ve misunderstood that I would need a vector layer beneath my image layer when filling with bucket tool, in fact it’s another bitmap-layer that I need so now it works… I just have my “Lines” layer and beneath that a “Colors” layer and the flood fill works without destroying my line work. :slight_smile:

Only bugs I found in the latest version so far are as I mentioned earlier.

  1. Zoom doesn’t work as expected. I need to press the shortcut key followed by a press with my stylus pen onto the drawing area to zoom in one level. Same with Zoom out. Simply pressing the shortcut key doesn’t work I need to do a touch-down with my stylus pen also. I use a Wacom bamboo.

  2. Using shortcut keys to go to Next/Previous frame doesn’t work. Nothing happens. I can only navigate through the frames by clicking on the actual frame number.

  3. I can’t drag the frames to a new position either, they are stuck where they are. They are also shown as “black/filled” in the timeline, just as is every frame is marked. Maybe that’s related to the problem.

All this could be a problem in just my build so you maybe you’re not having these.

just a small announcement, as to not having links everywhere i’m posting the download links for the Windows Builds here

http://www.pencil2d.org/forums/topic/pencil2d-windows-packages/

also please test these builds as to know if they have some dependencies missing or something, i’m already working on making 32bit builds

Thanks for your help Mr.Studio!

manu, in regard to the bugs, I will check this out next. I guess they are global to everyone. You should report them on the github bug tracker.

sure, but let’s say that i’m trying to save you some bug reports if it’s about the building process, call it a first filter, but now i have a question, regardless if it’s your branch or pencil everything goes on the main branch?

As part of fixing the vector engine, I am fixing the bucket tool. I am posting my updates on that matter in this existing topic : http://www.pencil2d.org/forums/topic/fix-the-bucket-tool/#post-27216

Imprint