[FIXED] MOVE tool not so responding

Last build (26Jul)
Win7 Ultimate SP1

The MOVE tool lacks consistent behaviour.
At first I wasn´t able to Move any shape after select it (on bitmap/vector layer)
Now suddenly the MOVE tool is starting to move objects but its movement is kind of jumping a little bit.
It is more noticeable when moving the shape up and down and when the shape is moved the first time.


  1. restart Pencil
  2. draw a shape (on vector/bitmap layer)
  3. select it with the SELECT tool
  4. move it with the MOVE tool…

AS soon as it starts to move you will notice its movement behaviour while dragging the shape

If you mean a stuttery movement, i see it in builds from recent sources, but not in the july 17 and previous releases. Seems almost like it’s trying to snap to something, and also seems to be more noticeable when it is being dragged and dropped around the same area as it was originally drawn (although i might just be imagining that)

Absolutely right @mikshaw, Seems almost like it’s trying to snap to something
That is what I meant :slight_smile:

that sounds like my changes broke something…

Same problem with zooming in and out. It is really slow.

Also double clicking to reset zoom, rotation and position to 0 is not working anymore.

All this was working in the previous version indeed.

I know only of Ctrl+H to reset the view. Where/what had you double-clicked before to reset? I’ve noticed that it will reset if the window is resized (which i assume is a bug), so maybe the double-click was triggering a redraw/reset in a similar way.

In 0.4.4b you could double click to reset the size if my memories are correct. I may be wrong though. Ctrl+H is good to know! :slight_smile: I also noticed that there is a menu for that. No need for double click.

It seems that the slow moving has been fixed on the last nightly build anyway!

I used to reset the view doble-clicking on the canvas WITH the HandTool selected. The recent build doesn’t work like that (glad to know that because it was kind of an issue)

The MoveTool issue is already fixed :slight_smile:

Big thank you @wesen
(I think you were the one who fixed it?.. Yesterday you worked A LOT !)

The thing about my program is that when I select the shape I want and move it with the move tool, it moves the whole drawing. Even the layers below it. This is quite a bother for me. Any answers? (IGNORE THIS I FOUND MY ANSWER SORRY I WAS USING THE HAND TOOL)