Exporting animations (5.4b version)

The problem I’m having is with exporting animations onto .avi (and have tried .mov and .wmv as well) and it doesn’t work. The console tells me to put the ffmpeg.exe into the plugins file, so I made a plugins folder and looked online for the plugin. I found it, downloaded it, and then put it in the plugins folder, but it didn’t work. What’s going on here? Any help would be appreciated!

(hopefully I’m not dumb and the answer wasn’t right in front of me the whole time, and if so, I’m sorry…)

I had that problem too. The best solution right now is to export your image sequence to an online gif maker. I don’t know how that works with more than two layers though, as I’ve only exported pencil tests.


What does the console window say, does it find ffmpeg at all ?

I personally don’t use ffmpeg because it’s output is not good, I get a lot of chunky pixels. What I do most of the time because I’m working on Windows 10 is to export image sequence to a folder, start Windows Movie Maker, select all drag drop into WMM, sekect all frames set the timing on each frame to 0.01 or something (i don’t remember) export the movie.

I don’t think it’s too much of a hassle actually, but it would be better if ffmpeg produced equally good results of course.


Actually I just made a random test on a Windows 7 PC 32 bit. Downloaded



Extracted to C: and made a folder called Plugins right at the same level where Pencil.exe is.


Extracted ffmpeg from the archive and put it in plugins, and it worked well.


So, I tried to install the plugin to be able to export movies, but I was unable to do so. When i try to export a movie, in any format, it will start to export, but once Pencil has 50% of the animation exported the persentage jumps to 100%. After that I check all of the folders is could be in, but I am unable to find it.

By the way my OS is Linux mint 17.

WMM way don’t work, and the ffmpeg way didn’t work either. With the Movie Maker method it will just show black, and the ffmpeg method causes Pencil to shut down.

Bit of a pickle here…

Thank you very much though for giving a hand! I really do appreciate it.


Don’t worry if WMM gives you a black movie, the problem might only be that you’ve drawn the line art in black (on transparent bkg) so you don’t actually have any background in your scene.

Just put a new bitmap layer on your Pencil2D animation, paint your background on it or just paint it white and export again and it should be visible in WMM.