EXPORT Movie >> Unplugged?

Last build (25Jul)
Win7, Ultimate, SP1

As title, nothing happens when applying File > Export > Movie > (any of the extensions)

It’s exporting for me, but always as avi (it creates movie.mov.avi, for example)

EDIT: seems my issue is a different one, which has been there since at least the Morevna branch.

Hi @mikshaw,

Do you mean that it is working fine for you when using .avi?

I mean when i go to export mov or wmv, it exports avi instead. Maybe it’s a linux weirdness. Sorry for adding an unrelated thing to your report.

Oh, OK. I think that that issue is related to Pencil on your OS. I remembered using a Morevna branch and it worked fine, for all the extensions.

Video exporter is a platform dependent issue. It means we have to implement 3 different video exporters on Win/Mac/Linux.

Apparently export movie is broken on Windows and Mac, the code is out of date.

But on Linux, Konstantin fixed it in 0.5 Morevna Branch.

trying 0.5.4b on a virtual windows XP, i got a console message telling me to put ffmpeg.exe into the plugins folder. I had never heard of plugins in Pencil, but i made a folder called “plugins” in the pencil folder, and put ffmpeg in that. Movie export worked for me after that.

EDIT: crashes when i try to export MPEG4/MP4, but seems to handle other formats properly

That’s a good news.
Well, at least, the first thing to do could be to have “plugins” directories already created when the software installs ? Maybe with ffmpeg in it for the windows version ?

OK, I’m running Windows 7 64bit - I created a plugins directory and placed the ffmpeg file in there and pencil tried to export : AVI 16 fips, 640by480 - until I received an appcrash… went into my debugger, and the problem was in the object.cpp method convertNFrames


else
{*framePutEvery = fps / *frameReminder; *frameSkipEvery = 0;}
}

–> fps / *frameReminder CXX0032: Error: divide by 0

fps was 16, frameRepeat was 1, framereiminder was 0

I don’t see where frameReminder is set anywhere prior to this method being called

int frameReminder, frameReminder1;

I changed it to 1 and retried the method, continued.

That worked… the avi was created. But I don’t know enough about pencil2d to understand what that frameReminder should be.

Hopefully this will help diagnose.

OK - just saw this: *frameReminder = exportFps % fps;

so frameReminder is being set to the modulus.

need an if 0

Thanks.