"Export Movie" just creates a blank MP4 or gives error message

When I try to export as a Movie (.mp4), it just creates a blank (duration 0:01) movie in the default Win10 “Movies” player, or an error in Windows Media Player (“Server execution failed”). Exporting as a GIF, in contrast, works perfectly. Am I doing it wrong, or is this a bug? I am on Windows 10 using the 0.6.6 version.

More details: I created a short animation with about 15 frames. Clicked File>Export>Movie. Clicked Browse and selected file location, changed name from untitled to my name, made sure ended in .mp4, clicked Save, then clicked “OK” on the Export Movie popup screen. Saw a brief “Generating Movie” popup with progress bar, then that disappeared and it said “Finished. Open movie now?”. Clicked Yes and it opens with the Win10 default Movie Viewer and just shows a blank movie with a 1 second duration. If I try to manually open the .mp4 file with Windows Media Player, it pauses for about 30 seconds, then an error appears: “Server execution failed.”

@seetak Hi, is it possible that you share your Pencil2D file with us? sounds like a windows problem rather than a Pencil2D problem but I don’t want to rule out anything, so if you share the file with us I can take a look at it and see if there’s anything specific that could be causing this issue from the Pencil2D side.

Thanks for your reply. Unfortunately, I just created an account and it says “new users cannot upload attachments”… do you know any way around that?

@seetak Right, this is usually the anti-spam system at work. We usually suggest all users to upload files to a free cloud file hosting service they trust to avoid size limits and privacy issues.

If you upload the file to, for example, a google drive account you can share an anonymous link simply by pasting it here.

As another example I personally use wetransfer.com for personal and work file sharing since it provides the ability to have anonymous links and it auto deletes files 7 days after upload (plus you don’t need to have an account for files under 2GB).

Whichever service you want to use is fine. If you still can’t, i’ll have to ask the webmaster for guidance on how to unlock your own permissions so it may take some time back and forth and I didn’t suggest it first since you may want the export issue to be solved relatively soon.

Okay, I uploaded my file here. Let me know if you have issues: https://drive.google.com/file/d/1h5Tb0a819oROmASsW77GfKZdvUfTISNH/view?usp=sharing

I appreciate you helping me with this.

@seetak Hi. When you click on the “share a link” option on the pop up window with the actual link you need to set it to be available to “anyone with the link” in the bottom part of said pop-up, otherwise I can’t access it directly.

https://support.google.com/drive/answer/2494822?hl=en&co=GENIE.Platform=Desktop#zippy=%2Cshare-a-link-to-the-file%2Cshare-a-file-publicly

Okay, I think I fixed it: https://drive.google.com/file/d/1h5Tb0a819oROmASsW77GfKZdvUfTISNH/view?usp=sharing

Hey, well I downloaded the file and exported an mp4, but I can play it back properly. I uploaded it to imgur to quickly preview it and it runs just fine. https://imgur.com/a/QMvvklq

Honestly I think the problem is that your windows media player is not suited to play specific mp4’s, for this you might need to download special filters called “codecs”.

What I usually do is I download VLC Video player and that usually plays almost every video file out there since it brings their own codecs pack already. https://www.videolan.org/

1 Like

Downloaded VLC media player. Works perfectly now. Thanks so much!

1 Like

@seetak I’m glad it worked for you :smiley: :v:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint