Everytime I copy and then paste in to the next frame, it fills in the paste

Everytime I copy and then paste in to the next frame, it fills in the paste, I dont know how to change it

@Trial Hi. Pencil2D has different timeline behaviors related to keyframe creation. By default Pencil2D preserves the current keyframe so it mimics how traditional animators think about exposure (which is basically how long should a frame be shown over time).

Unless you create a new empty keyframe to paste over the copied content, you will continue to paste on top of your current / previous keyframe.

Note that pasting will NOT create a new keyframe for you regardless of the selected timeline behavior under the Timeline > Drawing section in the preferences; this is an enhancement that has been proposed but it requires other dependencies (such as the implementation of the new undo/redo system) to be integrated without issues.

It’s also important to note that you NEED to move the playback header (vertical frame indicator) over the frame you want to modify.

So the procedure would be:

  1. Copy the keyframe content
  2. Create a new, blank, keyframe (the playback header should move automatically when creating a new keyframe)
  3. Paste the copied content from the clip board

If this is what you’re doing right now, double check the playback header position.

I’m not sure if this is still related to your other thread, so I’m hoping you upgraded Pencil2D as suggested.

If you have already upgraded your version, and after checking the steps above you still have issues, please try to record a video or a GIF of the exact issue as it’s presenting itself, sometimes what can happen is that a specific step is missing or there is an external input that messes up the expected result, so we have to rule those out before labeling it as a bug.

@JoseMoreno 1: nope does not relate to my other thread (Fixed that) 2: Kinda confused on what your saying and how you fix it but if you could say it more uh like understanding (Sorry I had trouble understanding)

3: I made a video anyways to show you my problem anyways

@Trial Ok I see what’s happening. The way you’re copy pasting is correct :+1:, sorry if the previous comment was confusing :sweat_smile: A few more questions then:

  1. If you copy / paste by using shortcuts do you get the same result?
  2. If you disable the onion skins by pressing the buttons on the bottom left panel. After pasting does it still color the selection “black”?
  3. By any chance did you fill the bitmap layer with a white color before drawing? If you’re not sure go to Edit > Preferences > General > pick the transparent checkerboard icon and see if the canvas background color changes for you to a semi-transparent bg?
  4. If you paste the copied image from Pencil2D into a different application (like krita or mypaint) do you get the same result as the GIF? (A black square)

Note for devs I’m thinking the combination between Debian(buster) along the chromebook could be making the Qt framework fail to support transparency when coping /pasting to/from the clipboard. This seems similar to what happens when you paste a transparent image inside Inkscape from the clipboard where it messes up the alpha channel and you end up with the image on top of a solid color that represents the alpha channel (in the user’s case, black for full transparecy). What do you guys think?

  1. Yes I do get the same results Crtl+C and then Ctrl+v

2: Yup, still black background

3: Still black background even if I change it

4: nope, works in krita

@JoseMoreno

@JoseMoreno I also use flatpak now, btw

1 Like

@Trial Thanks for the replies and sorry for the delay on mine. I’ll try to ask the developers to review this when possible, as it stands it is certainly a very odd problem, though i’m afraid if this keeps up you won’t be able to use Pencil2D at all :frowning_face:

In that case, if you can, use Krita as an alternative to drawing / animating and then you can use Pencil2D to export the final movie with sound (unless you prefer a video editor, which is actually a better idea for complex projects)

Ok @JoseMoreno Thank you so much for the help,

If a solution is found please Ping me as soon a possible . Thank you

Imprint