Everything is ORANGE!!! Paint Bucket on Vector

My scenario: I have created this awesome animation on vector layers but have yet to color any of it. When I went to paint bucket tool to paint my characters vest green it turned reddish orange instead. So I thought, “Maybe in Pencil’s universe green is orange, so orange must be green!?” but alas it was not and it was still orange. I also tried red, yellow, and blue, and they all show up as orange.

So I have heard many people had this problem, but have yet to hear of a solution. Any color chosen with the paint bucket on a vector layer will show up as orange. However the pen tool’s color works fine. Any ideas on how I could fix this or when to expect the next patch?

I know I can color on a separate Bitmap layer, but then I would have to re-draw everything on Bitmap exactly as seen on Vector or else it would look patchy. I could also color everything with pen, but that would take a hundred times longer than it would with paint bucket.

Please share if you found how to solve it. I am having the same issue, :slight_smile:

@soulsfanatic @mtg Hey peeps, Thank you for your patience and for writing on the forum.

Please let us know what version of the program you are using. It’s rather important to determine what’s happening.

If you don’t know how to find out just open Pencil > Go to the Help Menu > Press the “About” option > A little window will appear > Loo for an entry that has the following format “version: x.x.x (date)”

Also please let us know what operating system you folks are using, si it Windows? is it Mac? is it Linux (what flavor)?

For now I’ll pm @feeef who is one of the devs who’s been working on the vector part. Maybe he will help us a bit more or write down the issue to resolve it soon enough.

Thanks for the feedback!

You may try the latest build if it is not already the case. I have been doing many updates on the vector engine and the way it handled colours so this problem may have been fixed. I never had it with the current build anyway.

There is a video where I show the current updates and limitations of the vector engine here.

When colouring on the vector layer, you should make sure you use the colour palette to define your different colours. In the vector layer, each stroke and area is linked to a colour in the palette. If you update one specific palette colour with the colour wheel, it will live update all the strokes that are using this palette colour. I explain that in the video.

The vector engine is still not perfect and is such an important, useful part of Pencil for clean up, so I plan to do some more work on it. There are 2 things I want to fix :

  • The bucket tool not working on complex shapes

  • A stroke’s shape can be changed when making another shape close to its extremity (very annoying. I should fix this one quite soon)



Thank you for responding, I’m not sure what version of Pencil2d I downloaded, but if it helps I downloaded Pencil about two or three months ago and have not been aware of any updates till this point. Version 0.5.4 July 26 2013.

I use windows, on a Dell lab top with the Wacom Intuos Draw Tablet.

As feeef said I’ll try updating… But how do I update Pencil2d?

You can try to download the latest Windows build from here, unpack it where you wish on your hard drive and launch it as it is.

From there, you should be able to open your old Pencil projects.

I hope it helps!

Sorry if this is a stupid question, but I’m not computer savvy. The link brings me to multiple files, I see three that have “mac” which I believe stands for mac computer only, and the rest labeled “wid” which I believe means only for windows. I have a windows so I believe I should use those ones, but which of the “wid” files would I have to download? Or do I download all 0f them?

Also where would I go to download upcoming updates if any?

@soulsfanatic download this one since it’s the latest “Nightly Build” (December 19)

>> Pencil2D-win-20151219.zip

However please take into consideration that Nightly builds are works in progress, so not everything will work as expected, but hopefully your initial problem will be fixed, that means that where there is a stable release coming up you’ll be able to use it properly.

Once you get the single downloaded file right click over it and look for the “extract all…” option. There you can follow a few steps to unpack the file.

Once unpacked you have to find the pencil.exe (has a pencil icon) and execute it.

Let us know if things work as expected, If it’s not then I’m afraid we’ll have to find another way of troubleshooting what’s happening to you.

YES! It works. THANK YOU!

Ahh, new problem, the Pencil shut down on me and now I can’t open it back up. I tried re downloading it and downloading an older version but my computer won’t allow me to start the program giving me the error code 0xc000007b.

I can still use the 5.4 version, yet I can’t use paint bucket again.

@soulsfanatic I’m going to actually ask you to try something at a user level with the Nightly Build. Before trying to initialize the program do the following:

  1. Go to where the pencil.exe is located
  2. Right click and select Properties
  3. Go to the Compatibility Tab
  4. Turn on the “Execute this program in Compatibility Mode”
  5. On the activated dropdown menu select Windows 7
  6. Click Accept
  7. Right click again and press the “Run as Administrator” and input whatever password it ask of you (assuming you’re the only admin)

If this doesn’t work, we might have to wait for someone else to display a similar error plus a developer with windows 10.

On the other hand if it does work, it means the stability problem lies within windows 10 and how it handles Pencil2D files. Which wouldn’t be the first time for a new windows… In fact I’ve seen many issues with other commercial software on Windows 10.

Let’s hope it works! But whatever kind of different behaviour please report it here so we can take it into account. And while we’re at it Happy New Year!