ERROR IMPORT SOUND (MP3,WAV Microsoft PCM 16 bit) + video

Hello.

I have a problem with Pencil2D, when importing an audio it does not work correctly, I have seen [SOLVED] Audio not importing correctly and I have tried but there was no way.

I have recorded a video to make it easier to identify the problem:

https://mega.nz/file/rnhmzILb#_BA-MMQATy9Ccry3LG4ipFQ3o15SbIDJZP5YgJtf0YE

Thanks.

@s4tak Hi.

How to import sound into Pencil2D

Note: In version 0.6.5 Currently there’s an odd issue where you have to add the sound in a very specific way by using the add frame button in step #3

  1. To create a new sound layer either:
  • A. Go to the topbar menu File > Import > Sound This option will lead you to create a sound layer and will push you to step #2 and #4 automatically
    image
  • B. Go to menu Layer > New Sound Layer
  • C. Press CTRL + ALT + W
    image
  • D. Press the Layers plus (+) button on the left part of the timeline widget.
    image
  1. A name box will be prompted. Give the sound layer a descriptive name.
    image
  2. Once a new sound layer has been added, press the Plus (+) button next to the Keys label
    image
    OR Press F7 on your keyboard. This will create a new blank sound keyframe and immediately open a file explorer / folder browser to find your audio file.
  3. Find the file you want to import. Select it. Press Open.
  4. You should see an elongated keyframe that represents the entire duration of the sound. Note: You will not see a waveform; this is pending implementation.

:warning: Be careful not to import regular sound effects with the movie audio option, this option only works with MP4 / AVI movies.

If this does not work, we have to ask you to send us a copy of the PCLX file along the sound file you’re trying to import to investigate. Along that please provide us with a description of your computer specs e.g Operating system, hardware specs (i.e RAM, CPU, Sound card if available) as well as the Pencil2D version you’re using.

To get all of this information easily you can go to the Help > About menu and the press the Copy to clipboard button and immediately paste the information in your comment.
image
image

Note: Right now the other sound formats are in preview so they are not working. The only ones that work are WAV and MP3’s encoded with open codecs e.g Audacity’s L.A.M.E codec

Sorry, I already tried this. I am a new user so I send you a link that I am not allowed to upload data :<

@s4tak I saw the video you posted on discord, but you are using the sound loading process that uses the File > Import menu.

Don’t use that method for now, I mean please read the guide carefully and create a new sound layer with any of the other methods I provided, just don’t use the File > import option and add a frame to the sound layer instead.

I see you’re using Linux and this might also be part of the problem, but I only have Windows available to me right now so I can’t test.

Can you let us know what Linux distribution you are using?

Yes, I have already tried all the ways you sent me, regarding the distribution I sent you a link beforehand with what you asked me in the first message. What I can say is that I tried it from windows 10 and it did not give any kind of problem

@s4tak I understand. Thank you for testing all of that. I have downloaded the files you sent. Unfortunately I can also load the sound under Windows 10.

That means the issue you’re experiencing must be a bug unique to Linux distributions and I’m afraid it will take time before we can find what is affecting the software.

If you require a Linux animation software please try the latest Synfig release, or Tahoma 2D while we manage to work on this behavior.

@s4tak How have you installed Pencil2D? With the AppImage, the flatpak, or apt? If you are using the AppImage, try using the flatpak install (instructions are on our downloads page if you scroll down). Really trying all of these options is best as they all have there own benefits/drawbacks. You may also need to install the gstreamer package depending on how your distro is set up and how you are using Pencil2D, but this is usually already installed.

To install it I used apt, anyway I already installed tahoma as JoseMoreno said and it works for me. In pencil2d it made missing things like letters, circles etc. Thanks a lot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint