Dark Mode [help]


(Morgan Reed) #1

So, I install QT on several different systems and I always get the same error. The current install, however, while I can edit the code, building anything (including the examples) always results in missing the “imp” files. I will try to include screenshots of the error tomorrow, but for now, if anyone wants to build what little I could change, I have edited the UI files for a sort of “Dark Mode”. I would assume that you would just need to replace the files in the UI folder for this to work.

Also, i was going to create a “pull request” on GitHub, but i still don’t really know how that works…

https://drive.google.com/file/d/1xBn-petv9_uqoUSJCxAgIIu6WpCRqoOu/view?usp=sharing

Edit: Here is the ScreenShot of the errors. This was taken from building one of the examples, but i get the same errors when building anything - https://drive.google.com/file/d/1OmgCxD1QB0CmGyco1GaFVLNmnSd5NDQ8/view?usp=sharing


(Jose Moreno) #2

@velocireed I’ll alert the other devs about your thread so they can assist you further. But if you need to learn about pull requests please read this article: https://help.github.com/articles/creating-a-pull-request/


(Morgan Reed) #3

Thanks; I appreciate your help!


(David Lamhauge) #4

@velocireed Have you at any time been able to make a build of the program?
Personally I prefer to work on Linux (Ubuntu), but I always build my changes on Win10 and Mac as well, to see if it work on all platforms.
I have had some minor problems on Win10, but nothing much.
If you install Qt Creator, clone the pencil2d project from Github, opens it and runs it in Qt Creator, it should run without problems.
I saw your screenshot, and I don’t know what has happened there. Somebody wiser than must comment on that.


(Morgan Reed) #5

I have not been able to build anything, including the example projects. I will try to re-install QT again, but i’m not sure how much different the results may turn out. Maybe i’m missing something?


(David Lamhauge) #6

In your first post you write that you’ve tried different systems. What have you tried? Win? Mac? Linux? Did they all give the same errors?


(Morgan Reed) #7

I have tried before on my old windows machine and I think i finally got it working a year or so ago, but it hasn’t been working due to other conditions and old age. I also got it to work on my Raspberry Pi before it broke, but i don’t think i ever tried building anything, as i wasn’t as serious about C++ until recently