Crash When Trying to Export 1280 x 720

RE: LinuxMint, 6.6 daily build, 6.61 release, 6.11 in Linux Mint Package Manager

I tried making a video at 1280 x 720. This was just one PNG image file of text, which I imported into frame 1 and then copied over 40 frames. I then used the erase tool to slowly make the text display over the 40 frames. Very simple, looked perfect. No camera movement.

When attempting to export in any movie format: Crash. Details below -

Command: /tmp/.mount_pencilkmUitg/usr/plugins/ffmpeg -f rawvideo -pixel_format bgra -video_size 1280x720 -framerate 2 -i - -threads 8 -y /home/mic/001_Prime/Acer576g/001/videos/Pencil_Ani/the_jews_declare1 ffmpeg version 2.8.17-0ubuntu0.1 Copyright (c) 2000-2020 the FFmpeg developers built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.12) 20160609 configuration: --prefix=/usr --extra-version=0ubuntu0.1 --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-libx264 --enable-libopencv libavutil 54. 31.100 / 54. 31.100 libavcodec 56. 60.100 / 56. 60.100 libavformat 56. 40.101 / 56. 40.101 libavdevice 56. 4.100 / 56. 4.100 libavfilter 5. 40.101 / 5. 40.101 libavresample 2. 1. 0 / 2. 1. 0 libswscale 3. 1.101 / 3. 1.101 libswresample 1. 2.101 / 1. 2.101 libpostproc 53. 3.100 / 53. 3.100 [rawvideo @ 0x2268380] Stream #0: not enough frames to estimate rate; consider increasing probesize Input #0, rawvideo, from ‘pipe:’: Duration: N/A, start: 0.000000, bitrate: 58982 kb/s Stream #0:0: Video: rawvideo (BGRA / 0x41524742), bgra, 1280x720, 58982 kb/s, 2 tbr, 2 tbn, 2 tbc [NULL @ 0x22731e0] Unable to find a suitable output format for ‘/home/rick/001_Prime/videos/Pencil_Ani/the_shoes_declare1’ /home/rick/001_Prime/videos/Pencil_Ani/the_shoes_declare1: Invalid argument Exit status: CrashExit Exit code: 1 System Info Pencil2D version: 0.6.6 (nightly) Build ABI: x86_64-little_endian-lp64 Kernel: linux, 4.15.0-154-generic Operating System: Linux Mint 19.1 end

WORK AROUND - Export as an Image Sequence. This works. Use ShotCut to assemble your MP4 video or whatever other format you want. Its pretty simple:

  1. Export the Pencil2D image sequence to a Unique Folder.
  2. Start ShotCut.
  3. Select: Open File
  4. Navigate to the first image sequence file in the Unique Folder and click it.
  5. Click on the Properties tap on the Left side, mid screen for this file.
  6. Click the Image Sequence box - this will load in all other associated files with the sequence.
  7. Using the view controls, you can now play back the sequence.
  8. To adjust the “Frame Rate” Use the Frames per picture.
  9. For very slow animation, 16 frames per picture = 1 second per frame.
  10. Notice now, that total time of the clip shown under the player on the Left.
  11. Go back to Duration under Properties, and make the duration match what is shown under the player.
  12. Drag the Player video box onto the Timeline section.
  13. Your video is now ready to be played, further altered, or exported.
  14. When exporting, make sure you click Default, then edit Video size to 1280 x 720 or whatever you are using.

Cheers.

@CmdrMic Hey! In this case I’ll also ask to test with the flatpak version, but what strikes me as odd is that your FFMPEG flags say the framerate is 2 fps, while you mention in step 9 of your workaround that you’re doing 1 frame per second.

I think this may be the actual issue where too low a framerate can cause a crash, however I might need to test this on my own system to confirm.

In that case please try to export any of the other formats as well. There is AVI, WEBM and even APNG in the movie export dialog.

If all of these present the same error then it might not be a format specific issue (FYI MP4 has a lot of limitations for example you can only go up to 2048 x 2048 output size, and your height must be divisible by 2 or else FFMPEG will produce an error)

If possible can you share the file you used for further testing as well? If so please ZIP the pclx file and upload it directly on the forum post, or upload it to a cloud service you find comfortable, I personally use wetransfer.com all the time with their anonymous link option.

The issue appears to be with what you are saving it as. Please make sure that the filename you are saving it to has the correct extension at the end.

Thanks so much! Yes, when you go to save, you must manually add the extension, such as filename.mp4. (mp4, avi, etc.) Even though you select the desired format in the selection box, the save out routine does NOT add the extension for you and thus causes the crash. So, simply adding the proper extension to the chosen filename, fixes the issue. GREAT!

Thanks for that, turned out to be, just that the routine is written so the file extension must be added manually. I gave it another go with filename.mp4 instead of filename, and poof - no error, file generated perfectly. LOL.

1 Like

The extension is added automatically, but there are still some conditions where it has to be added manually.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint