Can't seem to fix my corrupted file

So, I’ve been working all day on a pretty short (1 minute or so) animation. My computer crashed right as I got finished, which I assumed was fine, as I had the file saved. However, whenever I went to open it, the file was corrupted. I did a bit of research, and I’m pretty sure my problem was that the audio track had Russian characters in it. So, I made the .pclx file into a .zip file, and I extracted it’s contents to a folder in order to rename the sound file. However, when I extracted it, all that was in the folder was the original .pclx file. I’m assuming I’m doing something wrong, but I’m not sure what. I just downloaded Pencil2D today, and I know I downloaded the latest version. Any tips?

@Laktoz_AJ Hey. Corruption has nothing to do with foreign characters anymore, this was fixed in previous versions and now the sound files are internally renamed when imported. However if you’re using Windows10 that’s the real source of the problem as we’ve discovered that it randomly denies saving the files when you are not the admin of your system, thus corrupting your files.

We have a guide to prevent these issues but we don’t have a definite fix: Pencil2D Project File Corruption Prevention / Partial Recovery Guide

Indeed in the guide it says that you have to turn the PCLX to ZIP to extract the file, but this is done by changing the file extension, not by zipping the file (which I’m assuming was what happened). Just in case the guide has a video tutorial on how to do this and extract the images.

In the guide the process is outlined but If you want share the PCLX file with us here either via dropbox, google drive or wetransfer and post the link. We’ll gladly inspect the file and recover whatever is still inside, however do know that it’s possible that some images were lost, particularly form the beginning of the animation.

I tried zipping the file at first, but then after watching the video I realized that I needed to change the file extension, so I did. The only difference from the video and what I did was that I clicked “Extract All”, as that was the only option I had.

@Laktoz_AJ Alright. If you’re still not being able to access the internal files please send the pclx file over. We can delete the link after we’ve downloaded it, and i’ll investigate it before I go to sleep.

Currently my account’s not old enough to send a private message. Is there any way that I could still send it over?

@Laktoz_AJ Just post the link here as a reply, i’ll delete the post once i’ve downloaded the file. Make sure you use an external file storage system like google drive or dropbox. Wetransfer.com can also do this and they have an anonymous link option as well.

Alright, here’s the link.

mod: This link has been removed at the author’s request.

@Laktoz_AJ Ok the good thing is that I could recover something. the bad thing is, as I feared some drawings were lost :pensive: Sigh, well I’ve sent over 3 different zip files:

  1. One contains the raw drawings that were recovered (original_data)
  2. One has a reconstructed PCLX file with the drawings that were leftover and are put along the timeline. This unfortunately does not preserve their original on screen locations so some of your pictures might be moved in contrast to their original positions.
  3. The last file is a PCL or so called legacy file (which it isnt) it’s basically an unzipped version of the project file which works the same in the Pencil2D editor.
    This way the files will be always available at the .data folder, but you have to move both the pcl and the data folder at the same time; they can’t exist without each other.
    This will hopefully reduce the permissions problems so files won’t get corrupted due to another bug that was fixed for the next version.
    However please also read the guide I posted earlier as I’ve updated some instructions for windows users to help minimize Windows10 shenanigans. But still it won’t be perfect so please always make extra backup copies whenever you can. all software is bound to fail, no matter the price or maturity :weary:

Alright, thanks so much!

@Laktoz_AJ You’re welcome. I’m honestly very sorry you had this issue, we’ve been fighting it for a long time and our devs still are having a rough time getting to the bottom of it, plus Windows10 recently messed up their permissions system as well.

If you need anything else let us know, and if the project due date is urgent I can recommend you alternative animation apps that are free just so you can finish your work on time :+1:

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

Imprint