Cant export as gif or mp4

hi so i just recently started using pencil 2d and i havent been able to export as a mp4 or gif. i can export images or image sequences. ive tried looking at other posts for problems like this but so far nothing has worked for me. i have the most recent version of pencil 2d and im using windows 10.

What happens when you try to export to these formats? Do you get an error message? If so, please paste the full contents of the bottom box of the error message dialog. There are several things that can cause issues during exporting, and we can’t tell what the issue could be in your specific case without this information.

To export your animation, to show them to the world, you require to have another program called ffmpeg loaded onto your computer. There is also a setup process to make sure that Pencil2D knows where it is stored.

hi sorry for the late reply. i get a message that says “oops, something went wrong” with nothing else. it looks like there is some sort of process that tries to happen before the error message but it goes away too fast for me to see

sorry for the late reply. what do you mean by that exactly? shouldnt pencil2d be able to export on its own as its something specifically in the program function menu?

@mashed_tots Hi. Unfortunately it seems the previous comment inadvertently created some confusion.

To answer you clearly: Yes, Pencil2D is expected to export movies & other media imagery formats. However it does so by leveraging FFMPEG a well established media plugin that even Autodesk Maya & Toonboom Harmony use themselves.

Regarding your other reply, is it possible that you can share with us the file itself so we can test it? You can DM it to me privately in case it has copyrighted content.

Right now, from your description Pencil2D should have very little to zero reason for giving an error during export, but there’s always something that might not be taken into account.

So I’ll assume that:

  1. Your computer is properly configured to run Pencil2D (Windows file permissions OK, Pencil2D installed on a legal app directory, all drivers & software needed likes MSVC is installed, etc)
  2. You extracted the entire software properly from the ZIP file (Pencil2D is portable, no installation but all files must be extracted to work properly)
  3. You’re not using an inordinate amounts of imported sounds that also happen to be on the same layer :loud_sound: (64 is the limit, Pencil2D is not meant to be a video editor, sounds is just for lipsync or beat syncing)
  4. You are using a standard screen resolution as camera size (1080p 720p 480p etc) (MP4 will turn an error when you enter a size not divisible by 2, and this is due to MP4 spec, not Pencil2D’s fault)
  5. Antivirus, or third party cleaner apps have Pencil2D added as an exception (in case drawings have mysteriously disappeared)

Just in case I’ll also mention an absolute basic because this trips a lot of ppl the first time, surprisingly.

To export you have to use File > Export > Movie > Browse > Enter file name > MP4 format by default (This is where FFMPEG gets in and does it’s thing)

Plenty people often try to use File > Save As… but that only saves the Pencil2D project as a particular Pencil2D file format. It does not change the format to whatever you coerce it to.

Anything else that might be effecting your experience could either be an issue stemming from a specific app, a very specific behavior occurring just while exporting, or a very specific element that was added to the app and we have no way of knowing without investigating the file itself, so let us know if sharing the file is viable for you.


For some of the output for example mp4 and animated GIF’s Pencil2D does this using an external program called ffmpeg. This is downloaded separately and must be installed where Pencil2D can find it.

FFmpeg is included with Pencil2D unless you are building from source. The average user should never be downloading FFmpeg manually.

1 Like

Hi Pencil2D users, I’m human I admit it. I’m sorry I made a mistake, I made a mistake in talking about loading ffmpeg separately. I have used several packages, which use the add on package!

ball bounce text kasljvh.pclx (28.3 KB)

heres the file. i think i uploaded it correctly but if i did something wrong tell me. thanks for elaborating on the previous comment. i checked everything you said and, assuming i checked correctly, everything is in line

1 Like

ok noted. thank you for telling me

@mashed_tots Ok this is weird. I literally opened the file, exported both MP4 and GIF, and didn’t have any error.

As you can see I managed to export both…

ball bounce text kasljvh

In case it helps:

  1. I opened Pencil2D
  2. I went to File > Open > loaded the file you shared.
  3. I immediately wen to File > Export > Movie > used these settings:


  1. Then I also exported it as a GIF by going to File > Export > Animated GIF


I even left the original file name which is full of spaces (not recommended) to try to make it fail, but it didnt…

Honestly I don’t know what could be happening… if anything I used a nightly build from March 12th. And I also tested successfully w/ the most recent one that was created yesterday.

tysm for doing all this, i got it working now. im not really sure what was going on either but i just downloaded the newest version from a few days ago and it started working. thanks so much for all the help


Thank you as well for all your patience while investigating this issue. I’m really glad you got it working too! :slightly_smiling_face:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.