Can't copy, cut, or paste


#1

I’m on version 0.6.2 mac. I tried copy and pasting using both shortcut and manually but it wouldn’t paste.
So I tried using cut and it worked the first time, but could not paste. I tried to cut again and it didn’t work.


(Jose Moreno) #2

@StarRiser Hi. This was a known issue ever since a few months ago and has been fixed already.

Please download the latest development version to have an up-to-date fixes meanwhile the new 0.6.3 gets released.

Below are the direct links for the respective OS builds:
Windows (7+ [x64]) : https://drive.google.com/open?id=1juDKIkv1F8fuNruGBwauA_y-7UNWibis
macOS (10.11+): https://drive.google.com/open?id=1l-Uv8LWVGHfI95dmZq2PUMOUn7s2JlpN
Linux : https://drive.google.com/open?id=1ZdDvZx_MC3yq5nMDXI0npCC0iA03l_nV


(Jose Moreno) #4

@GingerLemon This is fixed in the development builds, the ones that will become the next release version. To try them out please get the one appropriate for your system at http://pencil2d.org/download#nightlybuild

Also, remember that to copy and paste a drawing you have to use the select tool first.

Additionally currently you can’t copy and paste a keyframe on the timeline, only duplicate it.


(David Lamhauge) #5

@JoseMoreno and @GingerLemon I don’t know if it’s a new feature, but I can indeed copy and paste a keyframe on the timeline:

  1. Go to the frame where you want to paste the new keyframe.
  2. Press the ‘+’ button to create a new keyframe at that frame.
  3. Go to the keyframe you want to copy and press Ctrl-C (copy)
  4. Go to the keyframe you want to paste it to and press Ctrl+V (paste)
    Works like a charm!

(Jose Moreno) #6

@davidlamhauge I meant to phisically copy the keyframe container on the timeline layer itself, but you’re right you should be able to copy the canvas contents of a keyframe with the steps you described, thanks! :smile: