Camera not filling in frames

I have been following a number of Youtube videos to try and get the Camera to fill in frames so that I get a smooth transformation from frame 1 to frame 12. It just just jumps from the 1st frame to the 12 frame without filling in the extra frames. Hope this is clear. This is one of the videos I have been watching. Pencil2D | Move and Zoom the Camera Layer - YouTube Is it a bug or is it me:-) Cheers Mike

G’day, MikeX! This issue is, from what I can tell, VERY common. If this “jumping” of the camera happens in the editor itself, then you’re having the same experience as many people (including myself). This issue should not be a problem when exporting to a Movie. The camera still functions, but it doesn’t show the inbetween frames of its motion in the editor. If you really need to see the camera motion in the editor, then I’d suggest holding down the deselect shortcut keys (for me it’s Ctrl + D, but you should check yours) and playing it back. If this is not the problem, then please let us know!

1 Like

Phew JoeyH that was an amazingly quick response. Thank you. That works. I made a short movie and although its a bit jumpy that method does work. Thanks again MikeX

1 Like

@MikeX Hey, welcome to the forum. Fortunately Joey already replied with the correct answer.

As they mentioned the camera is working on export but as you yourself guessed the fact that’s not updating in the editor is a bug. Frotunately it’s already been fixed in the development versions, so it will work for the next release (TBA; Will bring a few big changes to the camera as well)

This is for @JoeyH as well. Currently in the download version there’s a trick to forcefully update the canvas painter so the camera updates.

If you playback through the animation either by scrubbing with the playhead or by using shortcuts, if your playhead is in any frame except the first frame, you can click on the camera layer, as if you were reselecting the layer itself, and you will see the camera updating.

This workaround works perfectly when using the next /previous frame shortcuts (comma , and period . ) to move the playhead. What’s important is to click the camera layer when the playhead is in any frame after the first one, then use the shortcuts and you’ll be able to scrub through while showing the camera motion.

This also works for normal playback, however everytime you playback and the playhead goes back to the beginning (1st frame) you’ll have to click on the layer again after the playhead moves forward, though you could use the range function to start the playback from frame 2 and even loop the playback to about this in general :grinning_face_with_smiling_eyes:

image

Enable Range and avoid the first frame

image

This is how the range would look when enabled

I’ll leave a GIF here in case it isn’t clear how to go about it. Hopefully we can release the next version before march. Have fun and happy new year to you both!

pencil2d_camera_workaround_0.66

Thank you, JoseMoreno; I never knew that! I will try that method myself!

Ouch! Thanks for that. I think I will leave it until the morning when I will be as fresh as a daisy… or not. Cheers Mike

Imprint