Audio Mutes After First Play

audio
windows10
bug

#1

Alright-

I can export the audio was a .WAV file into my animations with the sound layer and all. It plays the audio for the first run, right? I hit play, I hear the sentences, music, and things I need to hear in the animation. Say I need to re-position where the audio is on the timeline? I press pause, move it to frame one, and hit play. Suddenly, no audio. Why does this happen? I hear audio for the first time I press play, but when I restart the animation, the sound gets muted.


(Jose Moreno) #2

@injinlin Hi. First let me confirm some information:

  1. What is your current pencil2d version?
  2. What is your current operating system?
  3. How much RAM do you have?
  4. When using pencil2D are you having a lot of programs open along Pencil2D?
  5. Is the sound lost on the exported video? or does this only in the editor?
  6. How many sounds do you have in the timeline? by any chance is any of those sounds overlapping each other on the same layer? or are they on different layers?

#3
  1. 2019-3-30 Nightly Build
  2. Windows 10
  3. 8.00 GB of Installed RAM
  4. iTunes, but no music playing, Steam, but not using their playlist feature, and Discord. I use Voicemeeter Potato as a virtual audio mixer.
  5. This only happens in the editor, but is a problem since I can’t line up animation changes with audio cues.
    6.There’s only one sound layer, and I make sure to only import one sound at a time. No other sound layer is present, and no other sounds are imported.

I hope we can resolve this quickly.


(Jose Moreno) #4

@injinlin Thank you for your prompt reply. I see, so you use Voicemeeter as a way to solve the problems that came with Windows 7 and up where sometimes sound channels get “stolen” by other apps?

I thought it was that but then it would seem like it’s not the case. Unfortunately I don’t really know what could be the problem if it’s not that the other applications ended up using Pencil2D audio buffers.

If it’s possible for you can you send me a link to your project file so I can take a look in my computer? I have Windows 7, but If I manage to reproduce your problem at least I can ping the devs so they can take a look and fix it soon. You can use google drive or wetransfer if you want. I can later hide the link in case it has sensitive info, or if you want send me the link as a private message by clicking on my avatar.

However I’ll be up-front this might not get solved as quickly as we want it to since we never get these issues on our test machines and so far Windows 10 has been on the spotlight for recent issues, but nothing related to audio had been reported except an issue where someone also troubles playing back a sound, but in their case it would never play. In your it does play at least once. So it might be that there’s a problem with specific windows updates, maybe a driver too; we have to consider those as possibilities but it’s hard to test for them all.

I’ll also link a list of alternative animation software so you can at least continue with your work meanwhile we manage to triage this bug using the project file you share with us.

pencil2d-software.tumblr.com/post/145767476221/when-youve-worked-all-day-on-your-animation


#5

https://drive.google.com/file/d/1agfw_ptEeD0Z3zABe8eXmscZUwwQ3P7z/view?usp=sharing

^ This is the .pclx file of my project.

^ This is a quick recording of my issue.


(Jose Moreno) #6

@injinlin Hi. Thank you for taking the time to record the video as well. I’ve already put a request for the developers to review this thread, but the bad news is that although I’m testing your project file I’m not getting the same issue. I’m playing back, and even without stopping the playback, pressing the “go to first frame” button while it keeps looping too, and the sound continues to play properly.

If possible can you try looping the sound with a shorter range and check the sound mixer (windows mixer & voicemeter potato) to see if the sound volume keeps changing even after the editor sound is itself muted? This might help all of us see if at least Windows is acknowledging that sound is coming out form Pencil2D, because in that case it might not be a windows problem but rather a problem with a sound driver or similar software.

Something like this:
sound_mixer_pencil2d


#7

Even after switching the device in the volume mixer, no sound came out of the default speakers, whether I was playing the first audio run or not.


(Jose Moreno) #8

@injinlin Oh my god :sob: sigh I seriously don’t understand, I also tried just stopping the sound like a madman and it would still work afterwards. It would seem almost as if stopping the sound simply cut the audio stream inside the software.

Is it possible for you to try the following: Play it once, stop, let it play again without sound, then delete the sound and import the same sound again on the same layer.

If the sound comes back, let us know. If it doesn’t play then create a new sound layer and import the same sound over it and play it again. Let us know if it works or not.

Lastly, does this happen with ANY other sound? like doesn’t have to be a soundtrack. If it does or does not let us know as well.

For now these test will not fix the issue, but if we can at least ascertain that there is a trouble in the way that the audio streamer is working or something maybe one of the smarter devs can help review this problem quicker.

Also, I don’t want to say this, but this is looking like a really specific and troublesome bug. I work in animation so I know how important it is to solve these things quickly, and I’m really sorry so far we haven’t found even a probable cause, so my only real advice from here on would be to use a video editor and arrange the exported images there and adjust the timing from your animation relative to the soundtrack, since video editors have audio scrubbing. Only use Pencil2D to have a general sense of where the images are in relation to the soundtrack.

There are two applications I have used and know that you can get audio scrubbing. One is Opentoonz and the other one is Blender. Blender has a video editor incorporated where you dump the audio tracks and get them to work effortlessly when using the “grease pencil” object and tools. I have a 2-part webinar on grease pencil if you want to see that (I’ll only link them if you want to try that though), but it’s really easy to draw there. As for Opentoonz, it was working last time I used it but I’m not sure right now, however it’s worth a shot just so you can finish your work.

There are free “pure” video editors that you can try as well like:


#9

Here’s the third round!

I’ll use video editors, then. Thanks for the help, and I hope this is brought up and fixed. It might just be a problem with my audio mixer.


(Jose Moreno) #10

@injinlin I’m going to see if it’s possible for me to borrow a Win10 computer during the weekend. Maybe I’ll find something else. I’ll also take a look at your audio manager. If we can at least get to reproduce it we will be able to fix the issue for you and others that might be getting troubled by the same issue.

Since you tested the mp3 file, then we can scratch that the problem was linked to the sound codec for your current track. Thank you for all of your time to test this as well. If I know something else I’ll contact you through this thread. Good luck with your work!!! :tada:


(Jose Moreno) #11

Btw just found an old forum thread where someone mentions a correlation of bugs between voicemeeter and Qt applications.

http://elecraft.365791.n2.nabble.com/Hub4Com-tp7649520p7649529.html

Just FYI Pencil2D is built on Qt, a framework for creating graphical user interface programs. I’ll keep digging to see if there is actual proof for this claim, but I think it’s important to consider it as a possible cause of this problem.