Animation.exe has stopped working and will not open!

Well, my computer restarted without my permission, and when I tried to pull up the animation I was working on, Pencil2d said it couldn’t read it’s own file! The exact error says “Pencil cannot read this file. If you are trying to import images, use the command import.” I tried opening it with both the Open and Open Recent options with neither working. I tried to open it from File Explorer, but when it asked me what I wanted to open it with, it only gave me the option to look for an app on the app store. I can open a scrapped animation I did nothing with, but not the important one. Why?!
Someone please reply soon. I’ve spent several days on this animation and I really don’t want to start over. :confounded:

@MelodyAnimations please upload the file so a developer can take a look at it to see if it can be recovered.

I have a question though, were you trying to save the file when the computer was restarted?

Also please, read the FAQ here for tips to prevent losing work when this kind of issues happen:

Actually, I was trying to save it before my computer shut off, but I got an error for both manual and auto save. You already saw my other post about that. I’ll see if I can upload the file to that post so the developer can see it too.