Adding imported image, new layer on background layer

In this video the adding imported works: https://www.youtube.com/watch?v=o1AdNMBnOyk when I try it the imported image destroys the background layer completely

@adam-dunne Hi, welcome to the forum.

Honestly when you say the image destroys the background I have no idea what exactly is being destroyed, so without at least a screenshot of your Pencil2D interface it’s hard to say what’s going wrong.

For now I’ll mention a few considerations when importing images.

  1. If you are importing a second image over your background layer, you need to add the new image on a new layer. To import the new image to the new layer you must select the new layer first and then use the import functionality
    That means you’ll have something like this:
    image

  2. Make sure you are using supported image formats. Pencil2D suports out of the box

  • BMP
  • JPG / JPEG
  • PNG
  • GIF (Single image)
  • TIF / TIFF
    If you’re trying to import any other file format by changing the format extension on the file browser, this will not work.
  1. This might be obvious but sometimes people don’t obtain Pencil2D from the official website so I’m obliged to mention this. If you didn’t download Pencil2D from https://pencil2d.org please get the latest version from the website.

If none of this comments help, please post a screenshot or even better a video showing the problem directly so I can ask the developers for more assistance in case there’s an actual programming bug.

  1. import image 1 frame 1 only one layer 2)goto frame 12 3)Add frame 4)add layer 2 5)import image 2 goes to frame 2 (image stays the same)

6)goto frame 1 7)Play: shows image 2 only

(As I can only show 1 screenshot I am including the last one)

@adam-dunne Hi. Thank you for your reply. What I noticed from the steps you outlined and from your screenshot, is that the problem seems to be that you’re doing the steps in the opposite order.

A key point is that Pencil2D also shows any frame indefinitely on their respective layers until a new frame container is created after it to replace it in the same layer.

So what seems to be happening, according to the steps, is that you created the background on layer 1 & frame 1 but when you added the new second frame it was done on the same background layer instead, so the background will not show anything from frame 11 onwards because the background is now replaced by a blank frame instead.

After that since you added a new layer, this new layer is automatically given focus (you can see it highlighted blue) and as such it will be used to receive any new imported image, but since this new layer only has one frame overall, importing any image will append it to this existing frame and thus show it indefinitely.

Basically any image that you import will become attached to a frame container you are positioned over or a frame container that’s previous to the current empty frame position you’re located at, which in this case all points to the frame container in layer 2, frame 1.

The solution seems to be that you need to delete the 11th frame on layer 1, then add a new frame on layer 2. That way the background will be shown.

Now if this really isn’t the problem nor the solution applicable, please share the same file that’s having the problem with us and I’ll ask the devs to take a look. You can upload PCLX files in this forum, but if you want you can also share a direct link to a dropbox, mega or google cloud file. You could even share it via wetransfer.com which is free and simple.

Thanks Jose…that worked…all clear Appreciate prompt & detailed response

BTW one does need to set Transparency Tickbox on when (previously) exporting Image 2 As far as I can see, the default is off, & this should be mentioned in the YouTube tutorial I quoted.

Delighted with pencil2d…lovely package!

(BTW assume you are of Spanish descent…I’m Irish myself but live in India)

Hi Jose A suggestion:

  • Display all imported & exported file names: one often loses track! Perhaps you can direct me to appropriate place for “Suggestions”

@adam-dunne Related to your last comment, if you want to provide future suggestions for the software you can do so freely in the #ideas forum category.

With that said, if you want to change the output format the interface will change depending on the type of output.

File > Export > Still Image / Image Sequence As soon as you invoke the export dialogue, you can access a format dropdown box that allows you to change the resulting image format file type.

File > Export > Movie Similarly, when exporting a video file, this format selection also possible by pressing the [Browse] button and using the Save as Type dropdown box.

image

In this case adjusting the output format will also filter the files and show only the currently selected file format.

File > Import > Sill Image / Image Sequence / Image Predefined Set / Movie Video

When you invoke the import command, the file browser window will immediately appear. On Windows, near the bottom-right hand side of the window you’ll find a dropdown list for Image Formats

image

The same layout will apply for Movie Video output in the form of Movie formats

image

The still image / image sequence export windows are the only ones that have a format selector to help beginner users, however now I notice that the file browser does not have a format filter, which it is just as important to show the file formats as the import workflow.

I hope this answer your question and I’ll make sure to raise an request on the developer forum so the image export file browser also has the format filter implemented. Happy weekend!

Cheers Adam, apologies for not getting back to you earlier I missed the message on my e-mail reader.

First off, I’m glad that your main issue was solved. Regarding transparency, Pencil2D by default shows a visual representation of a white canvas, however this is simply a convenient illusion; in reality the background is transparent by design.

Certainly ticking the “Transparency” checkbox will allow you to export file formats that support transparency (e.g PNG, GIF) in case you require that. However since this is not often required by most users as they tend to export movies with coloured backgrounds, that’s why it comes unticked by default :slightly_smiling_face:

Imprint