Added Arabic Translation

I added Arabic translation on Transifex. But still working on reviewing it.
I compiled it to check how the new translation looks (with Qt Creator) but still Arabic is not shown in the Preferences.

These are the files I added/modified:
modified: pencil2d.pro
new file: translations/pencil_ar.qm
new file: translations/pencil_ar.ts
modified: translations/translations.qrc

Am I missing something for the translation to appear?

Regards,

1 Like

@shubbar Hi and thank you for contributing to Pencil2D. Hmm as far as I know the developers have to synchronize the translations on the source code themselves. I’m not quite sure how they do it, but as long as the new translation is added in transifex it will appear in the next version of Pencil2D.

I’ll ask one of the devs to see if we can give you a more clear answer so you can review the strings in your Qt build. :+1:

Hello, thank you for your contributions and interest. You were on the right track, but the languages are not automatically detected, so you need to add the option manually to the preferences dialog. To do this, go to app/src/preferencesdialog.cpp and right above the line:
ui->languageCombo->addItem(tr("Catalan ") + " (Catalan)", "ca");
you want to add the following line:
ui->languageCombo->addItem(tr("Arabic ") + " (Arabic)", "ar");
Then save and recompile and you should have the option to use your arabic translation file.

1 Like

Hey @shubbar, thanks for your translation work!

I just want to let you know I have added Arabic to the preferences. Pull the latest master branch and you will see it. By the way, I also updated the translations from Transifex this morning. You can check it out in the 9th Jan 2020 Nightly Build as well.

1 Like

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

Imprint