A few problems and a few solutions.

I recently installed version 0.5.4b of Pencil2D on my Windows 7 32bit system, and encountered some problems. After a bit of searching, I found out they are kinda common problems, and also found some solutions. But since the solutions I found were scattered throughout the Forum, I post them all here so they can be easily accessible in a single topic for the convenience of anyone else experiencing them. :slight_smile:

 

Bear in mind, these are the solutions that worked for me and my system, so there’s no guarantee that the same solutions will work for everyone else. Still, if there was a topic like this when I was looking for solutions, it would have made things much easier for me. So, here we go. :slight_smile:

 

Problem: I can’t import videos.

 

Pencil2D finally gives you the option to import videos for further study. Just go to File->Import->Movie, select the video you want to import, annnnd… Nothing happens! What gives?

 

Let’s take a look at the extremely useful console window. Apparently, a necessary plugin is missing. What you have to do is go HERE and download FFmpeg git-3bedc99 32bit Static. Extract, and go to the bin folder. There you will find ffmpeg.exe. Copy it. Then, inside the Pencil2D folder, create a new folder named “plugins”. Paste ffmpeg.exe there, and voilà: You can now import videos for study, rotoscoping, or any other use you want. :slight_smile:

 

Caution: You absolutely need to have a bitmap or vector layer selected before you import the video, or bad stuff will happen.

 

Problem: I import sounds, but I can’t hear anything.

 

Now this one is a little bit more complicated. Let’s take another look at the console and oh boy what is going on here?

 

WARNING: bool _thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded

“C:\Qt\4.8.5-VC2010\plugins”

“C:\Qt\4.8.5-VC2010\bin”

“C:\Qt\4.8.5-VC2010\lib”

 

Yup. Another plugin is missing. Let’s get back to work.

 

What you have to do is go HERE. Download qt-win-opensource-4.8.5-vs2010.exe and install it. It’s 235 Mb, so it may take a minute. Now that you installed it, you have the plugin you need. But we’re not done yet! If you try to import sound once more, you will see that nothing has changed and you still can’t hear anything.

 

Let’s follow the directory the console gives us. C:\Qt… A-ha! That’s the problem right there! The console looks for C:\Qt\4.8.5-VC2010</strong>, but the folder is named C:\Qt\4.8.5</strong>! Rename it appropriately, and voilà once more: You can now import and enjoy your sound clips, in both .wav and .mp3 format! :smiley:

 

Problem: I can’t export videos! Halp!

 

…Yeah, I still haven’t figured this one out. The program either looks like it exports the video perfectly, but when I look, there’s no file anywhere to be found, or it just crashes. I usually export in image sequences to further edit them in other programs, but the option to export directly to video file would be really nice to have.

 

What I found out so far: Part of the problem seems to be, again, with the sound layer. If I remove the sound, it exports the video perfectly. BUT, another part of the problem seems to be with the framerate! If I export a video in anything else than 24 FPS in the editor and 25 FPS in the export options, it crashes.

Any possible solutions about this one would be welcome. :slight_smile:

 

I hope this topic helps any other poor, unfortunate souls trying to figure out how to make Pencil2D work to its fullest potential. I will update it if I found out more problems and solutions. :slight_smile:

Thank you so much! I was having the same problem with my audio, thanks a lot!

thanks a lot! especially for sound solution, it works fine. just in time ! ))

Nice ! Thanks for this post !

@chchwy : could this help you too in the development ?

Yes, @gordie, embarrassing to say that I’m still working on these issues.

@piggy, Thanks.

(I would edit my original post to make it a bit more clear, but the EDIT button is not there for some reason. :-/ )

@piggy : I’m not sure about this, but it is possible that you can only edit your posts for a certain time. I can eventually check if I can change your “permissions” for this.

Guys, this topic was becoming a mess :slight_smile:
I splitted it into several topics, trying to keep it cleaner. Hope you don’t mind…

As said in the forum guidelines, please try to to have one topic for each idea idea being discussed. It’s easier for everybody to process / read / moderate ! Don’t be shy creating topics ! (just check there not already one existing on the same subject)

Thanks :>

Like many others, I have encountered the error where you can’t import movies. This guide is very helpful and all, except for the fact that this solution doesn’t work on Mac. There are a great number of Pencil2D users on Macs, and I found that this solution didn’t work. After a while, I finally managed to extract the ffmpeg-whatever, but then I couldn’t find the Pencil2D folder.

Ooooh nvm someone already said something about this

Just another accident. I wish I could DELETE these

Hi @piggy, I have tried your solution for importing movies (I’m importing .mp4), and when I have a Bitmap layer selected when I import the bar will fill to 20 percent, freeze, and then endlessly create new frames on the bitmap layer, and saying " Unable to load Bitmap image. TIP: Use bitmap layers to import Bitmaps." If I have a vector selected, it will load to 50 percent and then just stays there, creating infinite frames on the vector layer and saying “Unable to load Vector image. TIP: Use vector layers to import vectors.” (It’s been about 10 minutes. Any ideas of what I should do?

,

Can we expect a fix to exporting video anytime soon or is that still a work in progress?

@tyler_freedman Good day and welcome to our forums Tyler.

The video export capability has been included as a milestone (obligatory feature) for the upcoming version 0.6, however I can’t give you an ETA simply because Pencil2D runs on volunteering power.

At this moment in time most of our developers have been working as much as they can within their own spare time, but it still is a work in progress. If you need to urgently export any animation created with Pencil2D I’d like to direct you to this tutorial which was made recently:

Please also visit our FAQ & Tutorial pages for practical solutions meanwhile we wait for all of these important features:

FAQ: http://www.pencil2d.org/faq

Tutorials: http://www.pencil2d.org/tutorials#tutorial

I have had the worst of problems with this program.

I’m working on an animation for my spanish class, and have been working on it for a week. I was working fine on it, and added one more frame to my project before restarting my computer because my drawing tablet wasn’t working properly. When I turned back on my computer to continue working on it, a pop-up appeared reading, “Pencil cannot read this file. If you want to import images, use the command import.” Now, I had over 200 frames in this animation. When I opened the file that held all my frames and sounds, the frames couldn’t be read either, showing only a pencil icon. I had saved it before shutting down. My parents and I tried everything we could think of to get it back, but nothing worked. Eventually I just had to redo the whole animation. Yesterday, I spent all day on it, and got to over 700 frames. Now, the same problem happened on this one. I don’t know what I did, but I can’t redo it all again… Please, help…

@graceeguerra I’m honestly deeply saddened that this has happened to you and twice now. It is impossible for me to let you know through text alone how bothered I am by this issue.

If this problem is related to corrupted files I’m afraid that there’s nothing we can do. And I’m saying this after having tested the impossible on a similar problem that someone brought to me mere days ago. I attempted opening the files in obscure programs, recover the files with every app I could get, and even breaking into the files with a hex editor. Nothing worked.

I’m not a programmer, and I’m not a developer for Pencil either, I’m just an artist that wants to help the project, but I understand about machines to a point.

So If the files get corrupt, they miss their essential properties, or even worse, they get wiped, that means it’s like having a bag with a dead carcass inside, it has weight -file size- but it contains nothing of use. It would require a data technician to dig even deeper and get every option out there tested to attempt recovery, and that costs money, per file, and there’s no guarantee it will recover anything.

Pencil was never meant for long animations. It was initially a pencil test app, which means you can test out at most 300 frames tops with a certain degree of safety. Even now it still has a problem with large files.

Check if you’re using an old version (0.4.4 ~ 0.5.4b) because before after some time passed I noticed Pencil was REALLY BAD at the memory management, like it would eat up a lot of memory for a few hundred frames, so with all those 700 frames it’s a miracle it allowed you to work for as long as it did. I think this is exactly why the problem is manifesting itself, it’s simply not capable of withstanding that many frames past the 100 frames.

I know what I’m going to say it’s not going to be well received by other users who might have experienced similar problems, but after the first time you got the error, you should have sought a different animation solution.

I’m not trying to undermine Pencil as a tool, but seriously, this program is not meant for heavy production! We want it to become better, but it’s so hard to find people to help, so it’s still as rudimentary as it can be.

I can only offer you my sincere condolences. Also if you’re on a deadline, why not consider making a cut-out approach for now. Don’t draw every frame, and use specialized software like Anime Studio Debut, which costs money ($49.99), but it is a good investment.

For similar FREE options you can try SYNFIG (Windows is laggy) or TUPI, both vector based programs. You can’t draw as pretty in them, but they would allow you to tween the frames similar to flash, and that way you wouldn’t need to redraw all the frames.

If you’re not familiar with cut-out and tweens, imagine you have a puppet made of several parts each part would be on a different layer, and at least synfig and anime studio have bones that can connect those parts to make a real puppet, you would then go and animate faster with that assuming you don’t have many characters.

Objects in turn can be “tweened” that is, you just tell the program what is the initial position and the final position and it will interpolate the motion.

This is an example of a show I worked for which was done with the cut-out technique. Characters we’re cut-out, objects tweened and FX were hand drawn.

I don’t know how complex your animation was set to be. And it pains me to hear you’ve lost your work like this. So If you want, and your parents are ok with it I’m willing to help you out for free on my spare time if I happen to have some.

Maybe I can help with simple backgrounds or stuff. I’m super busy during the week but I could help at night if you’re really desperate about this. My time zone is UTC -5.

I know it’s not my business but I can relate to losing all your work like this because of (what might be) a stupid problem caused by the program.

If you’re going to keep using Pencil please then:

  1. first, check your version is not as old as I mentioned (0.5.4b and below) and try using at least one of the newer ones (Nightly Builds)…they are experimental but no-one else has complained about corrupted files or file wipes in the new version snapshots :confused:

  2. Everytime you’re working on a new set of frames create multiple numbered saves, like my_animation01 … my_animation020 …etc

  3. COPY and paste the .PCL file and the FOLDER files to a different place, always have a backup while the program is working…so if the program dies you won’t suffer :frowning:

  4. Export image sequences REGULARLY. That way you’ll at least have a flat backup if things go wrong, which you can retouch in photoshop or something if it’s needed.

Few questions/comments:

Copy it. Then, inside the Pencil2D folder, create a new folder named “plugins“. Paste ffmpeg.exe there, and voilà: You can now import videos for study, rotoscoping, or any other use you want. :-)
The windows installer could do it, no? What I'm trying to say is maybe the devs can add to the installer the creation of the folder "plugins" and the import of the plugin.
What you have to do is go HERE. Download qt-win-opensource-4.8.5-vs2010.exe and install it. It’s 235 Mb, so it may take a minute. Now that you installed it, you have the plugin you need. But we’re not done yet! If you try to import sound once more, you will see that nothing has changed and you still can’t hear anything.

Let’s follow the directory the console gives us. C:\Qt\… A-ha! That’s the problem right there! The console looks for C:\Qt\4.8.5-VC2010, but the folder is named C:\Qt\4.8.5! Rename it appropriately, and voilà once more: You can now import and enjoy your sound clips, in both .wav and .mp3 format! ?


Same here, those tasks may be automatically done, no?

I’m not here to say to the devs what they have to do ^^’ Just, it would be great to avoid the userdifficult steps of manually install the plugins!

@darckcrystale Hey thanks for writing.

Regarding your question: It’s not that it’s impossible. It’s that is useless for how the current program will work.

The solution for this problem that you’re quoting applies to version 0.5.4b which is 6 YEARS OLD.

In the newer versions, that we call Nightly Builds. Sound, video and everything inbetween has been disabled, not because developers love to mess with our users, but because they are looking for a great code library that will help them to make those functions available again, while being relatively painless to implement.

We sometimes get people saying “oh, why don’t you just use that OTHER program stuff”. Dude, it ain’t as easy as saying 1,2,3 UNO! they have to literally break the library “dna” code (just to give you a mental picture) and rewire it to Pencil’s own “dna”. It can take days, or even weeks working full-time. And we have spare-time volunteers, so imagine how much it can take.

In the future i’m sure there will be an installer that can deal with all this stuff, placing files and whatnot, but that is not at all the problem we’re facing right now.

Totally unrelated: I wish I could make a huge banner that would pass flying through the website saying “Pencil2D is not perfect, please forgive our sins!, before your burn us please visit our FAQ” hahahaha

Anyway, thanks again for writing. Take care and have a lovely week.

Yeah, I saw it after writing, but I couldn’t delete my post, sorry ^^’ (dates are on march, but of 2015, I messed with it)

I’m a developer too (web development, but I know a little C++ and QT). I see what devs do here with Pencil2D, and how it could be painful, I’m sorry for that :’( If I had more free time, I would propose myself to help, but I have already several project and a busy life.

For the banner idea: I use an application on my phone which display at first a message “If you’re thinking it’s not a very good mic, you’re right”, it’s funny, and clear. Maybe you could add your warning on the website description :smiley:

I really like those kind of projects, because it evolves. And I’m not really upset if it’s slowly ^^

Thank a lot for you replies and your involvement, have a nice day too :slight_smile: