[SOLVED] Choppy animation post export


#1

Hello,
I’ve created an animation using the latest version of pencil2d on windows ten, but when I play the movie after exporting it is very choppy/laggy. I have this issue if I use blender or ffmpeg in plugins. I have 225 frames and I’m trying to play them at 3fps, because the fps is so low the lag really disrupts the flow of the video. I’m wondering if it would help if I doubled or tripled the amount of frames along with the frame rate? also if that would help, is there a simple way to do that without going through each one individually? Thanks.


#2

@Gawain Hi. First of all, for your particular issue are you using the newer version of pencil2d? you should be able to export from Pencil2D without the need of Blender or the FFMPEG plugin as a external utility.

Please make sure you have the latest version found here: http://pencil2d.org/download

Now because you’re using 3fps to export, that would be playing 3 frames every second, so it would show as a really slow video. The laggyness / choppyness you mention is due to the slow playback from the FPS speed, or is it like a glitchy behaviour? Of course normally if you make your fps higher it everything will become faster but this is why planning out the speed before animating is important.

Normally when animating one has to set the projection speed equal to the platform or device you’re exporting to. So normally for quality web animation you can go for 24 fps and then time your keyframes properly to give you the visual speed you want. So if you want those 24 fps to behave as if you were exporting in 12fps, you’d have to place the drawings on the timeline every two frames, if you went for 8fps, then you’d have to place them every three frames, and so on.

If you still can’t solve it, please try to upload your file so I can take a closer look on the export settings, so we can have a developer helping if there’s a bug in the program.


#3

I’ve resolved the issue, kinda. The problem was actually with my media player being laggy, not something wrong with the export file. When I play my animation in mini view it runs smoothly at 3fps. I’m still a little confused because other videos run fine full screen. Hopefully when I upload it it runs smooth, I’ll have to do a test run. Thanks for your response though!


#4

@Gawain Glad to hear you solved it. I’ll leave the thread open for now in case you have any other input regarding this issue. If not I’ll close it then. Ideally we’re going to be using one thread per issue to avoid complicating things. Have fun!