Video export confusion

hello, always wanted to make cartoons and never had the tools so i love the intuitive interface pencil offers for the creation of ideas…so fun! trying to export seems like a lot of headache so far though.

i’m using a mac running 10.9.5 and using pencil2d 6.4 since it seemed the most appropriate. i’ve tried renaming, adding a .mp4, tried exporting as a .avi, and it just does this quick attempt at export and then disappears. i am never able to find the file on the computer…it just goes away. the project is fine and saved but…no export.

i’ve read a lot of replies about needing another program to make this seamless. is this true? any other last ditch efforts i should try? thank you, shane

@shane Hi. Welcome to the forum. First off, no, those replies aren’t true anymore. Pencil2D was unable to export movies 6 years ago, but that’s no longer the case.

Second, if you’re using a version for macOS 10.9.5, it means you are using a legacy OS ported version of Pencil2D. (please make sure you got it from the official download page at

The latest version ported for older macOS (10.7-10.11) should work, we were concerned there might be corner cases where it doesn’t, but so far no one has reported major issues (until now ofc). However from your description I may be inclined to think it’s a different issue and not due to compatibility problems.

In order to troubleshoot this issue please follow these steps:

  1. Go to File > Export > Image Sequence

  2. In the export dialog use the browse button and select a folder where you’d like to export your animation

  3. Once you enter the name and accept the folder location, make sure the filetype is added to the name (e.g MyAnimation -> MyAnimation.png)

  4. If the filename in the addressbar does not show the filetype, this is the problem. You have to add the filetype manually, once when typing the name of your file. If this didn’t happen ignore the comment and keep going.

  5. Once you have the filename ready, select the format below if you haven’t already. Selecting the format here will automatically change it on the filename above.

  6. Export and review if you have any resulting images in the folder you specified. If you do, then it’s possible there’s no problem specifically with Pencil2D, but we’d have to try different steps. Go to step #7
    If you didn’t get any images, then please go to step #9

  7. Ok, so let’s try to export the movie again, but trying to do the same as before and explicitly add the format when giving the movie a name and saving the file location like you normally would.

  8. If this does not work please don’t try exporting MP4 but try exporting other formats such as AVI, WEBM or APNG. If any of those work, let us know. If nothing works move to #9

  9. If you still can’t export anything, you might want to review your security settings by looking at this guide towards the bottom (allow unsigned apps to run) due to Gatekeeper which was introduced in 10.9.5: and then after a reboot try again to export “anything” either images or movies.

  10. If changing security settings didn’t work, please navigate to your applications folder and if possible open the Pencil2D app bundle to see if inside the folder structure, under plugins there’s a FFMPEG binary. If there is please continue. If not let us know.

Other than this if nothing works at all, I’ll ask the devs to take a look at your issue when they have some time, but meanwhile i’ll have to recommend you to take a look at our alternative animation software list so you can at least find a suitable replacement meanwhile they investigate the matter :pensive:

thanks so much for the quick reply, Jose. i did everything you said…and maybe its me… or the way my project is set up but none of the suggestions worked. i did number 9 and restarted to no avail. i tried number 10 but couldn’t seem to find any way to open the app bundle or folder from system folder. i’m not super pro computer guy though. thanks for the link to the other programs but honestly i used pencil a few years ago on another computer and loved it. tried toonboom for a month or two and never got the hang of it… the bummer is that i probably won’t put any more time into pencil until i buy a new computer (whenever that is) and can see it work successfully. really appreciate your help though. cheers

one other thing…i did the image sequence to a new folder and it worked. all 158 images were there. but then when i did the same thing with export movie…none of the movie setting’s worked

@shane Thank you for testing out the troubleshooting steps with this info I can ask the developers to review your issue. It is however a good sign that you can export the image sequence, for now you could use a free video editor and import the image sequence into it and if you need sound, you can easily finalize the video using the video editor soundtracks.

Regarding toonboom I get what you mean. I got certified on toonboom harmony a few years ago, and at the beginning I recall it being very alien to me, particularly because I had been using Flash for over 15 years.

After a while you kind of get used to the workflow, but I do understand it’s very difficult to simply “happen” upon the features you require to animate at first without proper training. Besides Harmony is just a mammoth of a program, it could be called a suite at this point, since you can do storyboarding, hand drawn animation, cut-out, 3D manipulation, bitmap & vector coloring pipelines, compositing, character rigging, and much more.

Anyway good luck with your computer. Hopefully Pencil2D can improve in the meantime so you can test it again later on (and have it hopefully work this time :wink: )

It’s probably an issue with ffmpeg. You can try downloading an old version which may work better here: You’ll want to unzip that. Next find the Pencil2D application in Finder and right click on it. There should be an option to “Show package contents” or something like that, click it and then go to Contents/MacOS/plugins. There should be a file called ffmpeg in there. Delete it and copy the ffmpeg file inside the bin folder where you just extracted the newly downloaded zip file.

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.