Undo and Hand tool issue

I installed Pencil and successfully got it to install, however there’s one problem I’ve had.

I use a pen tablet with two buttons that you could customize for a shortcut. It works fine with other programs but whenever I seem to use the first button (customized as Undo/ Ctrl+Z) it does undo the line I had made but uses the hand tool at the same time and makes it frustrating to work with.

I tried to fix this by giving the hand tool a different shortcut to use but it still seems to use the Undo/Ctrl+Z shortcut. My pen tablet’s driver has an option for Undo to customize the buttons, I thought that could have been the problem so I made a custom keyboard shortcut for my pen as Ctrl+Z, yet it still didn’t work. I re-installed pencil twice but I still got this same issue.

I really need help as I use Undo very often and it gets in the way if the hand tool is always opening at the same time as it does.

Hi @Smol_Wepa

Unfortunately modifiers eg. ctrl, shift and alt has a fixed functionality currently, that’s why stuff like the hand tool and eyedropper are triggered when pressed. It’s something we’re aware of, so it will be fixed at some point but currently no-one is looking into it.

As a workaround for now I’d say avoid using ctrl, shift or alt if this problem is too annoying.

Ah okay! I hope it gets fixed soon! Thanks so much for replying! ^- ^

Just to elaborate on @CandyFace’s workaround a bit, you should be able to change the keyboard shortcut for undo in Pencil2D’s preferences to something without ctrl, and then change your tablet button to match.

Ah I tried that, although when I changed it the hand tool still did the same thing before, the only difference was that it wasn’t changing the amount of zoom the canvas was in, all it could do was move the canvas around.

I am also facing the similar issue. I bought a new One BY Wacom drawing tablet. When I draw the images, in between a circle will show up around the tool and the tool changes to grab/Hand tool and on the next move the canvas start to move along with the movement of my pen. then I need to to do a tap in-order to make the tool back to drawing tool from that hand. It’s really annoying.

@harihkh Hi. If you’re using the Windows operating system along your wacom drawing tablet, please check this guide / reply and the sub guides linked in it: Wacom intuos jagged lines windows 10

Take your time following the guide as thoroughly as you can, but once you’re done if you continue to have issues then we can try to troubleshoot Pencil2D.

Unfortunately the problem you’re describing seems to be a direct result of a Windows issue that occurs due to Microsoft changing how tablet drivers interact with the Windows OS.