Tablet stylus not able to run animation

Hi,

I am using a Veikk A15 Pro graphics tablet. I am able to create my animation frames, however when I click the play button to run the animation it does not run. I have to point the stylus inside the frame and touch the tablet to get it to run.

However if I hit the play button with my mouse the animation runs fine.

I will be grateful to get some assistance.

dwild

@dwild Thank you for your report. We’ll have to investigate this, but it is possible that since your graphics tablet is from what seems to be a small brand, at least compared to big names like Wacom, the technology stack that Pencil2D uses as well as the drivers for the tablet are not compatible or at least are behind in obtaining full compatibility.

I’m afraid that we’d need to get a Veikk tablet to test for this specific issue, so for now, here are some recommendations:

  1. Make sure you have the latest drivers available for your OS
  2. Review that in your tablet settings and create a specific profile for Pencil2D. Not sure if this is possible with Veikk, but most tablets have this feature. Along that check that the double clicking threshold is high enough, it could be happening that the single click is getting acknowledged as a double click on the interface when it’s not focused.
  3. Assign a shortcut for playback workaround this. Go to Edit > Preferences > Shortcuts and assign a keyboard shortcut that’s easy for you to use while this issue is looked after.
Imprint