Sound not working in newest nightly pencil exe for me.

Is this for everyone or is there a way to fix this error. I can always go back and forth between the two versions I have to use the sound, but just thought I would mention it.

 

I tried .wav files and .mp3, neither worked.

And I guess You may ask what type of system I have. I have a windows.

No one else has this issue or no one has really seen this.

The sound doesn’t work for the nightly or the 5.4 version but when I use a slightly older version I can have sound, but is glitchy.

 

sound doesn’t work on Windows for me either. I get a warning: bool _thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded

Also discovered sound is crashing the program during playback on Linux =oP

I also had a problem with the sound - error was related to phonon. If I ran in debug mode in visual studio 10 (using QT 4.8.5) the sound worked. I tried compiling and replacing with the release version of pencil.exe… no good, needed the debug version.

So, I compiled a debug version and when I ran that in the Pencil directory, I received errors about missing dll’s. For each dll missing, I went into the QT bin directory and copied from there into the directory where my pencil.exe was located. Worked. Must be a phonon/qt version thing.

I had to copy the phonond4.dll, qtguid4.dll qtSvgd4.dll Qtxmld4.dll maybe some others. But at least I now have sound.

Hopefully this will help the developers pin down what the issue is.

Regards,

Al

 

 

Thanks, @nekogaijin. I’ll try to fix it in next release.

That’s good to hear. thanks Chang and nekogaijin