[SOLVED] How to manipulate windows?

As you can see, my pain wheel is quite defiant. SO defiant in fact, that I can’t move it no matter what I try.

I’ve tried: 1: left/middle/right clicking and dragging the gray top bar 2: closing and reopening the paint wheel window with the ‘x’ and the windows menu/toggling it in the windows menu

Is this a bug? Wasn’t sure and couldn’t find any documentation on it. The problem originated when I tried the little split window button on the paint wheel, which brought it to the corner of the screen. I wasn’t able to move that unless I resized it until the bar on top reappeared. Then, I dragged it back into the window where it is now.

@springleader Hi! Sorry to hear you’re having issues you can normally take the following steps

  1. Go to the menu Windows > Lock Windows > Uncheck Lock Windows and try to move the panel.

  2. If the previous step doesn’t work, then go to the menu View > Reset Windows. all panels will go to their default / factory state.

  3. If that still doesn’t work, let me know and I’ll give you more advanced support that involves deleting the registry file for Pencil2D. However this needs to be only used as a last resort, since if done incorrectly could potentially damage your registry.

I’ll be pending your response.

Thanks. At first it didn’t work, but after lock and unlocking the windows a few times and resetting them I regained the ability to move them. Resetting didn’t replace them in the default location if that’s what it was supposed to do. I’m liking the app otherwise.

@springleader Thanks for reporting back! Alright I’ll test about the resetting thing to see if there’s a possible bug to be found there and if there is Im sure the developer will gladly fix it for future versions.

If you have any other issue please be sure to let us know. And just in case, make sure to read the FAQ for healthy file maintenance habits so you don’t lose precious work.


After playing with the button for a while, I’m don’t think it’s a bug. The button only resets windows that were detached from the main window and puts them where they were last situated. I think this is a good thing if people wanted to keep their custom arrangement, but a second button to restore to the true defaults does not exist.

@springleader You are quite correct, did similar testing just after I posted the comment. I’ll make a request for a more definite command where the windows go back to a default state. However this might take a while since it would be best to pair this with a feature for having customizable workspaces or “rooms”. Thanks again for taking the time to test and comment :slight_smile:

I’m having a problem that the windows are going back to a position that I mistakenly got in place, and not the original default setting, so reinstalls do not solve my issue - and I cannot restore to system default if you see what I mean. So must I delete a .dll file? Thanks.