[SOLVED] Audio not importing correctly

sorry if this is the incorrect place to submit this, but i suppose this does classify as a bug?

i can import audio files and they work! but- not all of them? some of the only import to one frame, which means only 1 frame of the audio is played. other times, the entire file is imported and spans across all of the frames necessary to play the whole file. im not sure how to fix this?? all of the audio i want to use is only importing to the one frame so now i cant make the animation i want :’)

incase this can be fixed, my specs are- win10 64bit (anything more specific i can reply with)

Hey @pink-posh,
That’s indeed a weird thing if the audio length is only 1 frame. And you can’t hear it, right?

Would you mind to share us one of the audio files that cause the problem, so I can take a look at the code?

@pink-posh Thanks for letting us know!. Matt is one of the developers so he can help investigate this issue if you manage to link to the offending audio sample.

As an additional note I want to add two things. First, It’s adviced you use one layer per sound for now, since Pencil2D is not yet suited for heavy audio editing in a single layer :slight_smile:

Second, which version of Pencil2D are you using? If you can please go to menu HELP > ABOUT. And copy the code on the box. It should say something like this:

commit: e9aeb1a1cf711a5b36c9d4734181ee525ccacd84 date: 2017-11-14_23:22:11

Also, The Pencil2D team released a new version yesterday which has a lot of improvements, so if you don’t have that one, we encourage you to test it out as well, in lieu of your current issue with the sound samples.


thanks for looking into this :")

here’s a google drive of some of the audio files I’ve tried to use -

i am only using one layer and one audio file, i’ve read how easy it is to crash Pencil so I’m staying on the safe side and not doing anything too over-encumbering.
i have the version you released yesterday, actually! but here’s the info just incase-

commit: d573789a1315bc1afe52da4f255a1c0215351502
date: 2017-11-15_09:42:08

@pink-posh Thank you so much for your swift reply, it is tremendously helpful when people answer back because that way it’s easier to track the issues! I’m glad you have the latest version. Fortunately it’s not the final version :smiley: I’ll investigate this issue on my end, so I can help Matt to get to a proper solution quickly. For now it seems my test sounds are working but the sounds you linked all give me the same problem you mentioned.

For now I can offer you a small workaround. Please download the free program called audacity (http://www.audacityteam.org/download/windows/).

  1. Open the file you want with it.
  2. The re-export it as a WAV file. It appears as WAV(Microsoft) PCM 16bit signed.

It will be a lot bigger, BUT, you will be able to import the file now! I tried this with the one called “Can’t Sleep” by Kflay.

We’ll try to report soon meanwhile, but hope you can keep working while we’re at it!

@chchwy I was testing the sound samples and It seems it’s a problem with how the MP3’s were originally encoded.

I trans-coded each one of them to WAV files using audacity and they worked properly. I don’t have the MP3 dll for audacity but ill download it and test if audacity’s Mp3 export works as well to narrow down the issues.

When I export to WAV it says the original encoder was “Lavf57.19.100” apparently related to ffmpeg’s “libvo_aacenc”

On the other hand there’s still a slight but on how the sound layer is importing the sounds. I’ll create a report for that so we can work on it for a later version since it’s not a critical issue.

aa thank you!! it’s working now ^^

2 posts were split to a new topic: Can’t import mp3 sound with existing single frame

4 posts were split to a new topic: Sound file not being properly imported

2 posts were split to a new topic: Sounds do not play simultaneously