Save file wouldn't load

i’ve been working on the silly animation for 4 days and things when downhill, at the early morning it went fine untill i went to reopen pencil 2d and shows me this told me it was partially corrupt. i also tried to use the stable version v0.6.1 and the operating system is windows-64 bit. i did not have backup files because i didnt know that might happened

i felt incredibly dismayed for what just happened and hopefully there’s anyway to recover it back.

@misstuna Hi. First of all very sorry to hear you’re having issues. This is a problem that the Pencil2D team has been very involved in fixing after it was discovered.

I made a guide on how to 1) prevent this issue from affecting your work 2) attempt to partially recover the animation. Please read it carefully within the prevention guide there are links to the recovery guide as well.

Lastly, if you have any issue with the guides, please update this thread and i’ll gladly try to help you when I have some free time from work.

Edit: On a related note would you mind uploading your file to a cloud service of your choosing so the development team can review the file? We want to address this problem as much as possible as it’s been something that’s been creating discomfort among a few users ever since older versions and even though definite steps were taken to improve the issue, we have to yet still find the root cause it seems.

Edit 2 Sorry, also if possible can you copy the contents of that error message and paste it in a new comment on this thread? it’s important to help developers understand what has caused this.

Developer’s Note:

@chchwy @candyface @scribblemaniac

The file corruption problem has appeared again and this seems to be the RC version no less. That means the file saving issue is not yet resolved. I have asked for the file so we can inspect it but it’s possible that we have to consider an alternative method to perform the saving / loading and to be honest we should work on a partial backup feature before releasing this.

@JoseMoreno The screenshot may be from the rc, but we don’t know if the corruption happened in that version yet, so let’s not be hasty. “i also tried to use the stable version v0.6.1” makes it sound like multiple versions were used.

@misstuna What version of Pencil2D were you using to work on the file before it stopped opening?


@scribblemaniac my apology if my wording arent correct, my english is pretty off
originally, i was using the stable v0.6.1 first before i tried the other version. the error suddenly happens (like it was in the screenshot) before it would not longer open it

i have some questions because english is not my native language, so i had hard time understanding words

to edit 1: do the file that need to upload is the one that got partially corrupted?
to edit 2: do i need to reupload the screenshot i send earlier?

@misstuna Hi. Don’t worry about not being an english native speaker a few of us aren’t :slight_smile:

Anyway regarding your questions:

  1. Yes, that would be the file we would look at. The idea is that we can open the file and extract it?s contents. Sometimes the raw images are inside and we can help you get them. The guides I linked mention how to do it but for simplicity I’ll help you out then :slightly_smiling_face:

  2. No. Don’t worry. I was confused because you showed a newer version screenshot, and I assumed the saving problem wasn’t fixed. In fact i think you already answered scribblemaniac’s questions as well as my own assumption.

here’s the file that you want. if there is any error, let me know!

How do you think this happend did you download any software recently, that could have malware That corrupted it so try to think back to see how this happend then you might get an answer =)