Playing Sound & Exportin Movies


First of all thank you for those contributing to the development of Pencil, I hope to be able to contribute sooner or later myself. In the meantime I am doing some tests with Pencil in regards to playback precision testing the Pencil playback with simple “tock” sounds against an external metronome. Now with the old Pencil ( 0.4.4b ) I can play back sound fine, but with the latest from here ( 0.5.4b ) I cant hear anything ahen playing sounds in the timeline. I am using wav files btw and I am on a Windows 7 x64 system Athlon II X6, 16 Gb RAM.

Then I a, trying to export movie clips ( mov, avi, wmv ) so I put ffmpeg into a subdir of pencil. But everytime I try to export something Pencil crashes. Does anyone have an idea what is going on? Are there formats I should stick to that are known to be more robust than others?


Thanks in advance,



Sorry I just saw that movie export on Windows seems to be a known issue.



Same here in linux. Pencil2d crashes when I exported it to movie. Any idea if this will be fixed?



This may be a Fix for Movie Export Issue:

OK, I’m running Windows 7 64bit - I created a plugins directory and placed the ffmpeg file in there and pencil tried to export : AVI 16 fips, 640by480 – until I received an appcrash… went into my debugger, and the problem was in the object.cpp method convertNFrames

{*framePutEvery = fps / *frameReminder; *frameSkipEvery = 0;}

–> fps / *frameReminder CXX0032: Error: divide by 0

fps was 16, frameRepeat was 1, framereiminder was 0

int frameReminder, frameReminder1;I changed it to 1 and retried the method, continued.

if (*frameReminder>0) {
*framePutEvery = fps / *frameReminder; *frameSkipEvery = 0;
else {
*framePutEvery = 1; *frameSkipEvery = 0;
That worked… the avi was created. *frameReminder = exportFps % fps;

so frameReminder is being set to the modulus.

need to check if zero, and if it is, then set to 1

Hope that helps.

Yeah I cannot hear any sound when I play back my animation and when I try exporting any movie file, the file does not show in the folder I chose to export it to.

I am on windows xp.
I am not overly concerned about the sound issue, as I can play back the audio separately if I have to, although it is a pain and is much more convenient to have it on it’s own layer.

But I really need to be able to export this as a file that can be shared.

Hey! So sound doesnt work in Pencil2d which is important for lipsyncing and whatnot, here is what the console says about it for me on Windows XP


WARNING:Phone::createPath: Cannot connect Phonon::MediaObject < no objectsName > to Phonon::AudioOutput < no objectName >.


That is when I added the sound. This is what happens when I play through the frames…


WARNING: bool__thiscall Phonon::FactoryPrivate::createBackend<void> phonon back end plugin could not tbe loaded.

This message also pops up as soon as Pencil2d is loaded.


To me this seems like its a problem with the software not connecting with Phonon. I tried looking to see if it was maybe a problem with the .dll file though I haven’t been able to find the right version of the Phonon file, the newer version are for QT5, while Pencil2d seems to use QT4