Pencil2D doesn’t show up as an app or icon

this doesn’t even show up as an app or icon, it just a bundle of files that do nothing when you click them. I don’t understand what’s going on.
how do I get this to work?

Its like a portable application. No installation. Just unzip the file and go to the extracted folder. The open the exe file named pencil2d in the folder.

there no extracted Folder :frowning:

@JoeVyre Hi. Windows OS tends to be very jealous (particularly newer versions) of files that are not “signed” by official windows developers, so those tend to be “blocked”. After you download the ZIP file you have to unblock it.

To unblock a zip file you have to:

  1. Right click on the downloaded zip file
  2. Go to file properties
  3. Browser to the general tab
  4. Towards the bottom press the “unblock” buttont
  5. Press Apply and then OK
  6. Only then you’ll be able to extract ALL the files without issue.

Image taken from this guide:

If this continues to happen then you would also have to check your antivirus software and create an exception rule for the folder you are extracting your files to.

If neither procedure solves your issue, please make sure you are running your windows as an administrator. It is possible the UAC (User Account Control) is set very high and is not allowing any kind of program or DLL file to enter your system for that here’s a guide to disable it (if you are not the system administrator you’d have to ask them to help or get the password for your computer workstation in order to do this)

The last resort is to extract the program in another computer where it does work and copy that into a USB stick and then run it from there on your own computer.


So I seem to be having the same issue even after unblocking the archive.
Originally I user winRAR then just explorer with the same resutl either way.
A little loading curour and then nothing. Interestingly the duration of the loading icon is slightly longer on the first attempt after a clean extract and then it just blinks.

Im running on windows 10, not sure wich build but its pretty standard.

The last resort is a bit impossible for me otherwhise I would have tried it.
Also, wouldnt running the app as admin resolve the UAC problem? Such has been my experience, the little I have that is.

Another interesting thing. I downloaded and installed opentoonz and it seems to have the same problem

@Honin If you’re not an admin of the computer you use, usually running as admin is rather useless (and you couldn’t do it anyway due to login credentials). The UAC is a bit different because even for admins it tends to block “potentially risky” applications. With that said, even if you’re not the admin and even if the UAC is enabled, you should be able to extract the files without any issue.

The process sometimes goes like this:

  1. Download
  2. Unblock the file
  3. Extract All the files
  4. enjoy.

What you describe might be a third party software, like an antivirus causing grief. Normally industry grade AV’s like kaspersky or norton tend to panic about every file, thats how they can maintain high “detection rates” anyway, if you have an AV try to exclude the file.

The actual last resort is to extract the files on a USB stick using a different computer (school, work, etc) and try plugging it on your comp to see if it lets you run the software. If it doesn’t, or if any file has dissappeared then it’s more than likely that you either have a very aggressive antivirus / malware scanner or a virus itself that “hides” the files (not saying you do, this is just a possibility among many)

Edit: Actually I’m thinking that maybe it’s possible to dump the folder contents of Pencil2D into a dropbox folder and share that. But I can’t do that right now, so please try all your other options first. If none of those work then I’ll try to help with the dropbox option. If that doesn’t work then call microsoft support because you might be having severe issues with your computer if you can’t use other software because of that.

I compleately disabled the UAC, the first loading corsor lasted longer and then same as in the beginning. I have no aditional AV’s installed, nothing higher than Windows Defender.

Is there some way I can get debug information from the executable?

Because it does seem reasonable the the problem may be associated with Qt as that is also present in openToonz wich has the same trouble.

@Honin You could try to compile it yourself…but I’d advice against it if you don’t have experience with that. It’s just too much of a hassle for this to get to compile the entire software.

As for possible issues normally there’s been cases where QT files are missing or the PC needs Visual Studio redistributables, you can find that info under the “troubleshooting” section on

However as I understood it, your problem seems to be specific to not being able to extract the files rather than not having certain specific files.

Edit: Also QT files are dynamically linked, so even though Opentoonz might use QT libraries, they aren’t technically the same. Pencil2D ships their own QT libraries due to licensing related to the QT Company (Pencil2D is GPL, Opentoonz is MIT)

I find this very curios.
I am currently studying software ingeneering myself and it feels as though I need to know why this is happening.

As far as I understand DLLs the linker would complain letting you know that it cant find the file. Im not trying to sound smart or anything. msvcp140.dll is in its place and there are no issues. It may be because I have Visual Studio redistributable for 2017 installed currently.

May that be a cause of this curfuffle?

EDIT: I Uninstalled all distrobutions of the Visual Studio redistributable and installed the one from the package to no avail. UAC was compleatly disabled aswell as windows defender. But still the problem persists.

MS Visual Studio does not agree with my humble laptop and I havent tried using vsCode to compile it yet but I probably will if we cant find a end-level solution.

Im still curios if there is a way to trick an error message out of the app just to hint at the cause.

EDIT: I forgot to mention that I redownloaded the package and unblocked the archive, extracted it tried again with the same result. Im going to try and extract it remotely (like some potential bomb in an envilope) and see if that helps.

EDIT: I should really read more before posting, but heres something funny. Trying to setup the Qt SDK to build from source I noticed that the installer refuses to open in exactly the same way.

@Honin Honestly after reading your edits I think this is beyond my knowledge. I’ve never seen anything like it. And I can only think that windows 10 is actively denying the host services for any QT related files.

Maybe @chchwy or @scribblemaniac have more ideas as to why this is happening.

Now that you mention laptops is by any chance your laptop of Dell brand? I know there are issues with QT and Dell as mentioned here:

Funny thing. It is a dell. And you know what else is funny.

I restarted my laptop, and now everything is fine =.=

One hecken bamboozle. openToonz also works now. May be worth noting the restart seems to have fixed it. Time to not sleep any time soon

1 Like

I have no idea why this was happening, it’s very strange indeed. I’m glad you found a solution though @Honin. Sometimes turning devices off and back on again can work miracles :slight_smile: