Pen pressure not working

i turned off pressure sensitivity on one of my animation projects but when i tried to turn it back on, it wouldn’t work. I tried restarting my computer, closing and opening pencil2d, neither of those worked. It isn’t a problem with my tablet either, because pressure sensitivity works fine on other programs. I’m using v0.6.5

someone help ? : (

@cantdance Hi. Sorry to hear you’re having issues. What Operating system are you using? Also what is your tablet brand? Depending on that we can advice more accurate info.

i use windows 10 64bit and a VEIKK A15 tablet. thanks for the response !

@cantdance Windows10 I expected a bit due to the nature of the issue, but I’ve never heard of VEIKK tablets.

Let’s try something simple. The gist of most tablet related issues on Windows 10 is related to a technology called “Windows Ink”. Microsoft issued an update 2 years ago that messed up with all tablets, and basically forces everyone to use Windows Ink regardless of vendor.

If your tablet supports “disabling windows ink”, it is easy to fix. You simply have to go to your tablet driver settings and look for the appropriate option to disable it.

But specifically in the case of Pencil2D it’s not enough. You also would need to change the windows compatibility of the Pencil2d executable to Windows 7 so both Windows and Pencil2D can use the previous way of working with tablets before Microsoft deprecated it.

Please try to follow this guide for that

However, If your tablet does not support disabling Windows Ink from their settings or Windows “compatibility” doesn’t work with it, then things get a little more complex.

In this case there’s a bit of setup to do. Note this will help for every third party app, not just Pencil2D, so it’s still a good thing to do anyway, but you must leave windows ink option enabled on your tablet settings (if there’s an option):

  1. Windows logo key image OR Click on the Start Menu Icon image
  2. As soon as the menu appears, start typing and search for the OS Pen settings. Select this option.


  1. Once you click you’ll enter the Pen & Windows Ink Window. Change all the settings so they look like the ones below.
    Note: If you’re left-handed change the hand writing orientation to match yours.

  2. Press the Windows logo key image OR Click on the Start Menu Icon image again

  3. Type search for Control Panel image and select the matching option.

  4. A new window will appear. Look for the Pen and Touch option and click on it.

  5. The Pen and Touch settings dialog will appear. Make sure to uncheck the optiosn on the Pen Buttons section. Seles the Press and hold list option and the [Settings…] button will appear. Click on it.

  6. Once you click the Settings button, the Press and Hold Settings dialog will appear. Uncheck the Enable press and hold for right-clicking option.

  7. Press OK to go back. And OK once more to close the Pen and Touch settings.

  8. [Optional] If by Any chance you also see a Flicks Tab disable the checkbox as well.

  9. Also consider trying out one of our latest development builds which have certain improvements related to how tablets are handled, however since these are experimental you will probably run into unexpected bugs, so use this mostly for testing if your tablet works or not with Pencil2D’s latest improvements:
    Win64 bits
    Win32 bits

After doing all of this your tablet should start working with Pencil2D. If not please let us know as well.

Final Note: Don’t forget to restart Pencil2D after changing these settings. If you do all this while the program is running you probably won’t see any change.

None of these seem to have worked : ( I’ll probably be able to adapt my personal animation style to fit my problem if I’m totally unable to fix it. I appreciate the help anyway! :_) Maybe the next update will fix my problem haha

@cantdance Unfortunately if that didn’t fix you issue, it’s possible the separation between the tech Pencil2D uses, the Windows 10 operating system and your tablet drivers is too wide.

At this moment in time I’m not sure it’s a problem that will ever be “fixed” considering pressure works for most tablet brands including HUION, WACOM, UGEE, XP-PEN, ARTISUL, and others I’ve seen mentioned around here.

I’ll share a list of alternative animation software that you can try instead so at least you can continue animating in the near future:

Thank you for trying out Pencil2D anyway :slightly_smiling_face:

i really appreciate that ! i’ve used pencil2D for a while now, and if anything at the very least it’s been a great learning tool for future programs ! : ) thanks for the help !

Bonjour J’ai le meme probleme et j’ai une wacom Intuos avec win10. Ca fonctionnait bien avec la 0.6.4.

I have the same problem and I have an Intuos wacom with win10. It worked well with 0.6.4.

@mcsblanc Please read this reply for a comprehensive answer: Wacom intuos jagged lines windows 10

TL;DR: This is a joint problem between Windows10, Wacom (and other tablet brands) and Pencil2D’s foundational technology, the Qt Framework.

If you follow the guides in the reply I have linked above, you should be able to get pressure sensitivity back.

I have the same problem and I have an Intuos wacom with win10. It worked well with 0.6.4.

I too have wacom & windows10 but to me it has never worked after a Windows10 upgrade from 2018. For more info you can read this reply by WACOM:

I’ll quote from the article:

Important: Some applications require Windows Ink to be enabled to use pressure sensitivity (for example Adobe Photoshop). In that case, you need to disable Windows Ink for “All Other Applications” and enable it for Adobe Photoshop (and any other application that requires Windows Ink for pressure sensitivity).

Pencil2D is one of those “applications” so currently the solution is to either disable windows ink and change pencil2d.exe compatibility to windows 7 to force Windows10 to use the legacy winapi drivers, or configure windows ink properly.

This problem goes beyond our own capabilities and we can only apply certain improvements, but unfortunately users will have to put in effort to customize their Windows10 installation at least once, for the foreseeable future.

Merci pour ces explications. Par contre cela ne fonctionne pas. Mais ce matin, j’ai regardé de nouveau dans “propriétés de la tablette Wacom”, cliqué sur le bouton “Options…” puis décoché l’option “compatibilité pression”. Et là ça fonctionne à nouveau. Si ça peut aider quelqu’un !

Thank you for these explanations. However, it does not work. But this morning I looked again in “Wacom tablet properties”, clicked on the “Options …” button and then unchecked the “pressure compatibility” option. And there it works again. If it can help anyone!

1 Like