Nightly Builds Nov 2 2016 bug report

  1. The pen tool doesn’t work properly on a bitmap layer, every few strokes it seems to work just fine but most of the time it doesn’t start painting immediately after touching the tablet screen, instead it just slides along with my stylus for a while and then it suddenly kicks in and starts painting (It seems to have something to do with how long I keep my stylus down rather than with how much distance it travels)

  2. The stylus buttons don’t work properly, the lower one doesn’t switch to the eraser and the upper one works correctly but doesn’t stop my tools from leaving marks while I move around and zoom in on the screen

  3. The shift + swipe shortcut for increasing the brush size doesn’t work

  4. The fill tool doesn’t work on a vector layer at all and is bugged on the bitmap layer, sometimes leaving rectangles or straight lines instead of filling (Seems to work fine inside a shape I draw, but if I try to fill the space outside of that shape or a completely empty frame it goes nuts)

System Win7 x64
Using Wacom Intuos Draw

I just can not draw without having an eraser bound to the lower stylus button, so I tried out some other versions to see which one is the last where it worked.

Turns out it’s NB Mar 9 2016. And the version prior (Jan 16) was the last one where the shift+swipe shortcut worked.

Also the pen problem seems to be tied to whether or not I have pressure sensitivity enabled (it breaks when I do)

Hope this helps

@alankalane Hmm the problem might be related to specific Wacom Drivers for the Intuos Draw.

I have a Wacom Intuos Pro 5 and it works great, actually Nov 2016 was the first version I could ever draw on. The rest felt horrible to me.

Pencil2D aside, your issue reminds me of something. Due to an unsolved issue that comes from WACOM itself, I ALWAYS have to restart my tablet drivers whenever I want to use any drawing application.

If by any chance do you see some kind of “rings” that appear when you click this is a well-known issue that Wacom users have to face on Windows.

Normally you’d have to do a lot of stuff to make it work as expected, however I’d suggest you to follow this guide to see if your drawing experience improves. This is like step one every time you want to use a Wacom tablet on windows.

Note that this is not a Pencil2D issue. It’s a problem with Wacom drivers that even pro artists suffer from.

However if you follow the guide and your experience doesn’t improve I’ll see how I can put a bug report with your specific tablet. But i’ll also like to ask you to take a couple of screenshots to highlight the issue and post them here.

  1. So far the eraser mapping was optimized for Wacom tablets. With mine when I flip my pen it immediately switches to the eraser function (not it doesn’t change the tool icon and will use whatever eraser settings you have configured on the tool).

  2. Yeah it was temporarily removed because it was interfering with other functions. When they stabilize the program more I think they will bring back those quality yof life improvements.

  3. The fill tool issues are already known, the problem is that since there’s so few people working on the project it has not been possible to fix it further, although last month a guy did work on it a bit, but it introduced a bothersome issue with the vector tools since they are trying to make “vector merging” possible. So for now it’s broken, but they will work on it eventually :wink:


  1. Nvm the May 20 release fixed this for me

  2. But my pen doesn’t have that flip functionality, and I still can’t access my eraser via the lower stylus button

  3. I am sorry to hear that. You know what,

it just so happens that I am a 2nd year IT student,

and it just so happens that C++ is my main language (mostly WinApi and .NET but I think I could dig into QT too)

and I just so happen to like the program and I am also looking for something to put on my CV so…

Yeah, if you’re looking for a programmer I’d be glad to help. But unfortunately I’m nearing my exams and I wouldn’t like to get distracted so I can start as soon as I am past them. If you agree of course.

@alankalane That’s actually pretty cool, good luck on your exams. By no means I’d like this to distract you from that. The project can always use any help, and what I tell people is that if you can at least code one line, that’d be more than enough to get the app going.

Devs usually gather at the github repository here:

I’m not a programmer myself, I can only help by modding and testing the app, all of us are volunteers, considering this is a FOSS project, but if you ever want to help this project it’d be awesome and more than welcome. Soemtimes it feels more like a personal project than anything, but I do want to at least make it possible to get funding in the future, however I’m not the owner of the project nor the head. I just woke up one day tired that the project was dying and tried to gather whatever we had left to get things done, so I’ve been at least trying to maintain the social media alive, and I’ve been compiling feature requests and bugs from other animators and users over several months to get a roadmap done.

Pencil2d has a long road ahead, but it will happen little by little, of that I’m sure. Thanks a lot for getting interested and I’m glad that part of the issue you had is fixed now.

p.s. When drawing and I want to erase I use E then switch, I never flip the stylus lol. I think you could bypass this issue by creating a specific layout for your wacom tablet. You can make a particular app have it’s own configuration. After that i’d setup the button to press the E for me only for Pencil2D. Since there is currently no “soft-switch” enabled (pressing and holding to switch temporarily to a different tool) you could also use you tablet buttons to switch again for the brush or pen tool.

If you want I can make a video of how i’d do it on my Wacom Intuos, I think the driver gui should be similar, so let me know.