Issue down loading


(Brad the inhaler) #1

I’m a newer user to Ubuntu and I’ve tried a few times the Command line from the website and the built in software manager and fail each time. any way when i run the comman line it says that pencil2d doesn’t exist. Can any one tell me if the instructions on the main page have changed or is there a common error for some unbuntu users?


(Jose Moreno) #2

@Pencil_420 Hi. Currently software managers will not have an updated version of Pencil2D. And there is not repository enabled for console download to my knowledge Edit: Please read Scribblemaniac’s answer below.

Debian repos can be found here:

https://packages.debian.org/sid/main/pencil2d

However we supply both AppImages and Flatpack methods to install across linux distros.

We currently recommend using Flatpack mainly because the Pencil2D team is fixing several issues that have been reported on linux platforms and most of them appear on Appimages but not on Flatpack distributions.

If you want try out both:

Appimage

Download the official release as Appimage go to our download site. Currently we haven’t announced the new release but you can peruse the 64bits version; the 32bit version is being built right now

To learn how to use Appimages please see this guide: https://itsfoss.com/use-appimage-linux/

Flatpack

You can find the flatpack repository here:

https://flathub.org/apps/details/org.pencil2d.Pencil2D

This one should get you the previous 0.6.2 version, as I mentioned we’re still updating all the downloads across the different ports.

If you require a guide for Flatpack visit their official guide for Ubuntu: https://flatpak.org/setup/Ubuntu/


(scribblemaniac) #3

Appimages and flapacks are both options, but we have apt packages too and I consider them the best option if you are on the latest distro.

Are you following the command from our downloads page:
sudo apt-get install pencil2d
If you are and the installation was successful, then you can simply run pencil2d with the command pencil2d, or by locating Pencil2D in the GUI application list. If this is not working for you, then we will need more information to tell what’s wrong. What is the output you get when running the installation command above? What version of Ubuntu are you running?


(Brad the inhaler) #4

I tried the first suggestion and it’s currently installing. Thank guys, I’m on Mint if that helps. the latest build as of last week. I’m pretty n00b so thanks for the point in the right directions.