Export not working in legacy OS X version

When trying to export an animation, regardless of format, the program does not actually create any file, despite a progress bar being shown. This applies to the latest version running under OS X 10.7.

@langrock Hi. Can you take a look at the follow reply on a different topic and see if it helps you solve this issue?

If it does please select the comment as the “solution”, if not, please report back if GIF’s and Image sequences are not exported either or if it’s only a problem with the movies…

Thanks for the help. The version in question is 0.6.4, which I think is currently the latest stable version. None of the export options result in a file being created on the computer. Is there a way to look at debug logs?

@langrock Ah, that’s unfortunate I was hoping it would fix your issue. I’m afraid I’m not sure what else to suggest at the moment.

If it’s possible for you could you setup OBS or any other screen capture program to record a video of all the steps you’re taking from opening the software to exporting your file so we can see if there’s anything amiss? Please try to export the following:

  1. An Image sequence
  2. An Animated GIF
  3. A Movie

As for debug logs these versions don’t have them so to get them you’d probably have to compile the software on your own, but I honestly don’t know how one should create the final build with plugins and all :thinking:

Also I’ll ask the developers to see if they can comment here to help you further with more macOS related support; unfortunately I’m using Windows so the amount of help I can give is limited to previous reports :pensive:

I have tested the legacy version, and can confirm that on mine MacBook, it will not export as mp4. The progress bar is visible for maybe 0.2 seconds, but closes as soon as the export fails.

I’m no expert in Mac, but my best guess is that ffmpeg fails for some reason. I tried to export a frame, and there was no problem there.

edit: Just tested to export as gif, and it was the same as mp4. The progress appears, but is aborted soon after, and export fails.

1 Like

@davidlamhauge Thanks for testing David! that means we can reproduce it then. As you say it might be an issue with the ffmpeg version, as we had this problem once with Windows (IIRC) and had to use a patched version for release.

Hopefully the others have a better idea of what could be happening.

That sounds promising, thanks. At least it appears that it isn’t a configuration issue then on my machine. On the other hand, there will likely only be a very small numbers of users benefitting from a fix. So maybe it isn’t worth spending too much time on this. We can always export the project and load it up on a less ancient machine to export to a movie file or GIF.


@langrock or @davidlamhauge Can you please try the instructions found here: Video export confusion

I can confirm that it work fine, if you follow the description in the link. Thanks!

Sadly, no luck on my end. Replacing the ffmpeg version results in a message upon export that Pencil2D had to quit, despite the program actually not crashing at all. No file is being created on my computer. Will check again later tonight.

As I wrote, I tested it and it worked fine @langrock , but what I didn’t realize was, that it shouldn’t just be the software that was ‘legacy’ - the laptop should be too…

I was testing an a newer macBook, so my test was indeed misleading. I hope they are able to help you. I’m unfortunately not…

Got it to work this morning! Steps I took included installing the Xcode command line tools, compiling the x264 library, and finally the 2.8.x version of ffmpeg. There were some hiccups along the way, so if there’s interest, I can write up what worked for me and also upload the compiled ffmpeg executable. Thanks for pointing me towards the solution.

Good job! I’m sure that was quite a bit of work.

There were some hiccups along the way, so if there’s interest, I can write up what worked for me and also upload the compiled ffmpeg executable.

Yes I would be interested in both, however the binary will not be useful unless you compiled it with the --pkg-config-flags=--static option.

I can compile ffmpeg once more tonight with that option. Unless the computer dislikes this, I can attach the compiled binary.

In summary, I had to take the following steps to create a version of ffmpeg that enabled the export function in Pencil2D under OS X 10.7.5 on a Core 2 Duo MacBook.

  1. Install the Xcode command line tools following these instructions or these updated instructions from the same author.

We now have a working C compiler (gcc) to compile ffmpeg and the required x264 library.

  1. After downloading the latest x264 source code from here, we can configure the compilation process

./configure --enable-shared

and compile using


followed by

sudo make install

  1. After this, we are now ready to compile ffmpeg. I tried this for the 4.x branch, the 3.x branch, and the last 2.8.16. Only 2.8.16 compiled without errors on my system using the following configuration settings

./configure --enable-libx264 --enable-gpl --enable-shared --disable-doc

Without the last option, the compilation process would error out when the texi2html tool was being invoked despite that tool being present on the system; maybe not the correct version. No big deal, since I didn’t need the documentation to begin with;-)



sudo make install

worked as expected. I then copied the compiled binary ‘ffmpeg’ into the Contents / MacOS / plugins folder under the Pencil2D application. Et voila! The compiled file can be found here for a while.

1 Like

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

@langrock If you get a chance could you please give this version a try and make sure:

  1. It runs on your computer
  2. Audio playback works
  3. Video export works

That would be a huge help for us as none of our development team has an OS X 10.7 computer to test it on.