Editing image erases everything

I have seen a couple of similar issues in the forum, but those threads had no responses! So, hopefully this thread doesn’t share a similar fate…

Pencil v0.5.4, running on XP

I have an animation with two bmp layers, one background, one moving images (simple, cars moving in a straight line).
Background has only a couple small changes (traffic light color), one background key every 5-10 car keys.

The problem is this: I duplicate a background image frame. Then I make a small change to the newly duplicated frame (bucket tool to change the color of a “light”). So far so good… then I make a 2nd small change (same as before, but in a different “light” circle) - and instead of the expected behavior (filling in an enclosed region), the entire image in completely erased.
Once that happens, ANY editing I try to do (drawing, selecting and moving, erasing) erases the entire image.

The only way I can continue working on the image is to go back one step, save, close the program, and reopen it.

When it finally reopens, I can again make ONE change successfully, then the 2nd change will erase everything. Since it takes so long to save and to open each time, it takes several minutes to do any one thing.

In addition SOMEtimes when I try to duplicate a frame, it just creates a new blank frame (less than 1/2 the time, but more often than 1/4). I can not find any pattern to when “duplicate frame” works and when it doesn’t.

I also had the jumpy twitchy “move selected object” mentioned in another thread, but I found a workaround by using the arrow keys to move the selected part of an image instead of the mouse.

Please tell me there is some simple fix that I’m unaware of!
If this continues, not only will I never finish the animation in time, I may very well start crying.

But wait! there’s more!!!

Every once in a while, instead of erasing everything, when I try to do (any editing task), it simply freezes while the background cmd screen infinitely scrolls : “QImage::pixel: coordinate (23xx,13xx) out of range” (where xx = increasing digits - its too fast to read, but it looks like it may be going from 2300,1300 up to 2399,1399 and then starting over, again and again)

Again, there doesn’t seem to be any pattern (that I have found) as to what triggers this. If I close the program, reopen it, and try the exact same thing (usually filling in a small area with the bucket), it will usually work normally.

Thank you for your report @jacobaziza It’s true, some of those have no replies. The forum has begun to regain activity just recently. Although I’d like to ask of you to report this on the github tracker.


That’s truly where the developers hang out and that way they can organize priorities to improve the program.

If you want copy / paste what you said here, over there. It’s possible though that this has been reported in the past, but due to the amount of issues and few developers working, it’s difficult to fix everything in a timely manner. Either way thank you once again for taking the time to report this; these kind of projects are in need of responsible users and devs to work everything out.

Hi ! Sorry to report I wasn’t able to replicate that behaviour on Windows 7. No problem there with same version. (32 bit). I tried to do like this :

  1. Made 15 frames, on first bitmap layer.

  2. Drew some moving objects there.

  3. Added another bitmap layer, with one frame

  4. Drew to filled cricles with some colors.

5 Duplicated that frame , bucket filled them with another color placed the frame on timeline (5) and did the same thing for frames at timeline (10 and 15).

I hope that was what you also tried?


Sounds like you did the same steps as me.
But the problem I ran into didn’t happen at first. It started happening over time, as I kept adding frames and making adjustments, it got slower and slower, first it crashed after every several changes, and eventually it was every change.
But I have a theory now: I tried a different program, which was a little more stable but still painfully slow, and realized upon trying to zoom that my images were enormous (background thousands of pixels across, and individual elements more than a thousand). Something to do with importing an existing image, and then scaling the background to that, and then zooming out.
When I shrunk it to a more reasonable resolution, the other program handled it fine.

I suspect the Pencil / my computer couldn’t handle processing so much.
But I don’t know, cause by the time I figured that all out, I just kept with the alternate animation software I was using by them!

I tried going back in to shrink it just so I could report back here, but I can’t find any option to adjust sizes of layers or canvas or anything.

@Jose Moreno, I was gonna report it there too, but you apparently need an account, and I eventually got my project done…
Thanks for your reply though, and to everyone who participates in making and maintaining open source software!

Thanks for your feedbacks @jacobaziza!

Version 0.5.4 has always been quite unstable and I am currently working in fixing the bugs and making a 0.5.5 version that has the same features but is much more usable.

I am myself an animator (who used to be a software developer) and I decided to give some of my time to make pencil my main animation tool. And make anyone else benefit this dev as well.

Currently, we come up with about one bugfix build per week until we get to a stable 0.5.5 version. I believe this should happen quite soon though. Hopefully before the end of december.

If you like using Pencil2D, feel free to come to this website and get the latest nightly build. It should be more stable and usable each time.

Thanks anyway!