Difficulty with Tablet


(Keith Fieldhouse) #1

Hi,

I’m not sure if I’m running into a bug or I’m just “doing it wrong”. I’m new to Pencil2D. This problem occurs with the latest Pencil2D 0.6 on Mac OS X.

I can easily draw a circle on a single frame with a mouse. Now I’m trying to use a HUION H420 tablet, with the latest drivers installed.

All of this is with the “pencil” tool.

When I draw with the tablet I get this fairly weird behavior. I attempt to draw a circle and a set of thick straight lines get drawn. At the same time at a much slower pace a lighter version of the circle that I’m trying to draw appears. This lags many seconds behind the cursor movement. I’m a novice both with a tablet and with Pencil2D so there are any number of things I could be doing wrong. Any hints, pointers or suggestions would be greatly appreciated.

Thanks,

Keith


(Matt) #2

Hey @kfieldho

Sorry to hear that. Definitely something went wrong and we are willing to fix it. But we need you to give us more clues so that we can work on it.

Did it happen only with Pencil tool? how about Pen tool and Brush tool?
Will you be able to give a screen recording? You can simply do it with QuickTime, Go to File->New Screen Recording, and then upload it to Youtube or somewhere else. We can see what actually happened. Thanks.


(Keith Fieldhouse) #3

I believe pencil and brush tool I didn’t try the Pen I don’t think, I’ll confirm tonight when I’m back at my system. I’ll also capture and upload a video of the behavior then as well.


(Keith Fieldhouse) #4

I’ve posted a video of the behavior on YouTube at

https://youtu.be/em0l2zjjPnE

I can confirm (and the video shows) that the behavior shows up with Pencil, Brush and Pen tools.

I hope we can figure this out. The more I look at the software the more it seems like exactly what I want. A chance (as a complete non-artist – see my circles in the video) to play around with hand drawn animation.

Let me know if there is anything I can do. I’ve been a Mac developer in the moderately distant past, if that helps.

Thanks again,

Keith


(Oliver) #5

Hi @kfieldho

Would you mind telling which version of Mac OS you’re using, the lag issue looks familiar to something we’ve experienced before. It’s acting pretty weird though, drawing two different lines too… hmm.

I can’t reproduce the behaviour on Mac OS Sierra.


(Yams) #6

I have the exact same problem; the lines lag behind my pen movements and create extra straight lines between curves that I didn’t draw. I’m using a Huion H420 graphics tablet with the latest drivers, and a the 2018 Mac air. I tried downloading Pencil 2d again with a supposedly newer driver and it still didn’t fix the problem. My problem is pretty much exactly the same as @kfieldho.


(Yams) #7

I’ve looked all over the internet and there seems to be very little on how to solve this problem, except for a link for a new driver, but I tried it and it didn’t work.


(Jose Moreno) #8

@yams_12 If you’re using the latest version of Pencil2D, then I’m afraid the only thing I can do is report this to the devs and recommend you to use another animation software while this is fixed :slightly_frowning_face:

You can see a list of alternatives on Pencil2D’s blog here http://pencil2d-software.tumblr.com/post/145767476221/when-youve-worked-all-day-on-your-animation


(scribblemaniac) #9

@kfieldho @yams_12 I recently bought a very similar tablet (the Huion H430P) so I am now able to test this issue. Out of the box everything was working fine for me (in Pencil2D at least). For the moment all I can recommend to fix the issue is:

  1. Use the latest nightly build of Pencil2d
  2. Make sure you’ve got the latest Huion drivers for the correct graphics tablet model
  3. In the Huion driver settings, disable the “Linear Optimizer” option:

Now that I have the hardware to test with, investigating and fixing the issues our users have been having with Huion tablets is high on my todo list. Hopefully we will have some solution for the next stable release which will probably come in the next month or so.


(Yams) #10

Sorry this isn’t related to pencil 2D, but how do I access the settings for my Huron tablet? I cant seem to find how to disable the linear optimizer.


(scribblemaniac) #11

@yams_12 You can access the settings by opening the HuionTablet application in /Applications/HuionTablet.app. If you do not have this application, you should download and install the correct one for your model from huion’s website: https://www.huion.com/download/. Please try this and let us know if changing that option solves your issue, I am optimistic that it will. It is possible though that the driver version for your model doesn’t have this option, also let us know if this is the case.


(Yams) #12

I’m pretty sure the driver version I have is the latest one; I only got my tablet recently, and downloaded it again multiple times while trying to fix this problem. I think the driver version for my model doesn’t have this option because my Huion applications app only has a pressure sensitivity test and options for my pen and express keys, but no driver settings.