Can't Import JPG to Camera Layer

I’m not sure what I’m doing wrong, but I’m trying to import an image to my camera layer so I can create a panning background. No matter what I do, or how many different images I try, it refuses to accept my JPG image file and gives me the standard error message that tells me to import bitmaps to the bitmap layer (even though it’s definitely not a bitmap). This also happened when trying to import a PNG. I’m on Win10 and using the most recent version of the program.

@TheMaestroso88 Hi, welcome.

I’m not sure what I’m doing wrong, but I’m trying to import an image to my camera layer so I can create a panning background.

I’m afraid this would be the very problem. A camera layer is meant to “see” the drawings, not to “hold” the drawings.

image

This image shows the bitmap layer being selected and importing images will work as expected

Every and any bitmap image should go into a bitmap layer (:large_blue_circle: blue color) otherwise you won’t be able to import it. Also you MUST select the layer where you want to import the media.

This is a rundown of how the basic media layers work, and how they might work in the future:

  1. Bitmap Layer: Accepts videos (Image part), Image sequence, Still Images, GIF’s
  2. Vector Layer: (WIP, not working) Will accept Vector file sequences, still images (e.g SVG)
  3. Sound Layer: Accepts videos (Audio part), Individual SFX, individual OST (various filetypes are supported as long as they are encoded with standards compliant software i.e no online converters, rather use audacity)

Hi Jose,

Thanks for the response. I see my misunderstanding from before, but I’m still unable to import my image even when selecting one of my bitmap layers. It gives me the same error message. This is true whether or not I have already created a frame for the layer, and for every bitmap layer I have.

EDIT: I got it to work by resaving the image as a png first, which probably shouldn’t be necessary, but at least I solved that.

@TheMaestroso88 Hi. Hmm can you share a compressed folder (zip) of the files you’re trying to load then? I may be able to investigate this before handing a report over to the developers. You mentioned you had to save the image sequence as a PNG, so I’m wondering if the file format you were trying to import in the first place was compatible with Pencil2D :thinking:

If possible please share the original sequence by using a public file link like those you can have with google drive, dropbox or mega.

Also can you tell me exactly which options you are trying to use? e.g. File > Import > ?

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

Imprint